Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 613803 - ip / ifconfig appears to not work in single-user mode
ip / ifconfig appears to not work in single-user mode
Status: CLOSED DUPLICATE of bug 585053
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-12 16:46 EDT by Need Real Name
Modified: 2014-03-16 23:24 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 12:32:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2010-07-12 16:46:20 EDT
1. Boot into runlevel 1
2. Edit /etc/sysconfig/network-scripts/ifcfg-eth0, and change NM_CONTROLLED=yes to NM_CONTROLLED=no
3. /etc/init.d/networking restart
4. ifconfig

(no output)

5. ifconfig -a

(no output)

6. ping 1.2.3.4

(I get output)

7. ip addr

(no output)

Something is going wrong here... same as if I run with ifup eth0
Comment 1 Jiri Popelka 2010-07-13 08:12:46 EDT
Steps to reproduce:

1. telinit 1

2. 'ip a' or 'ifconfig -a'
(no output)

3. setenforce 0

4. 'ip a' or 'ifconfig -a'
(work as expected)
Comment 2 Daniel Walsh 2010-07-13 08:31:36 EDT
This is a known problem, which we are changing by forcing the running of sulogin.

If you execute sulogin, the terminals will work correctly.

Or you can do a little trick by executing

ip a | cat
Comment 3 Bill Nottingham 2010-07-13 12:32:03 EDT
Actually, we're not forcing sulogin, but we're putting another command in between so policy can work.

*** This bug has been marked as a duplicate of bug 585053 ***

Note You need to log in before you can comment on or make changes to this bug.