Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585090 - After Rebooting Machine, gnome-shell Now on Wrong Screen and Not Displaying Correctly.
After Rebooting Machine, gnome-shell Now on Wrong Screen and Not Displaying C...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 02:26 EDT by David Le Sage
Modified: 2011-03-26 11:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-26 11:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing sidebar on right-most screen and black bar instead of top "panel." (3.82 MB, image/png)
2010-04-23 02:28 EDT, David Le Sage
no flags Details
Screenshot of another idiosyncrasy that I just discovered: alt-tab's "sub menu" for multiple open items now spills over the two monitors. (2.14 MB, image/png)
2010-04-23 02:37 EDT, David Le Sage
no flags Details

  None (edit)
Description David Le Sage 2010-04-23 02:26:54 EDT
Description of problem:
I have been using gnome-shell without any major issues for a few weeks on my dual-head system.  Today, after rebooting the OS, I find gnome-shell is behaving differently.  Whereas before it would default to the left-most screen, it is now launching on the right-hand screen (the old gnome-panel still launches on the correct screen.)  Furthermore, the top panel is not displaying.  After several minutes of use, the right-hand screen goes blank, so maybe this error is related to X.

Version-Release number of selected component (if applicable):
gnome-shell-2.29.1-4.i686

How reproducible:
Every time.

Steps to Reproduce:
1. Reboot machine (I have been running yum update on Fed 13 on a daily basis.)
2. gnome-shell --replace.

  
Actual results:
gnome-shell launches on right-most screen.  Top bar of shell does not display.

Expected results:
gnome-shell should default to left-most display and the top bar should display correctly.

Additional info:
Comment 1 David Le Sage 2010-04-23 02:28:39 EDT
Created attachment 408503 [details]
Screenshot showing sidebar on right-most screen and black bar instead of top "panel."
Comment 2 David Le Sage 2010-04-23 02:37:57 EDT
Created attachment 408507 [details]
Screenshot of another idiosyncrasy that I just discovered:  alt-tab's "sub menu" for multiple open items now spills over the two monitors.
Comment 3 David Le Sage 2010-04-23 02:41:38 EDT
Just noticed in the above that both those terminals are reflecting gnome-shell output.  However, I only run gnome-shell --replace in *one* of them.  The other was launched from the sidebar once it was running and I did *not* issue any commands in it.  Why would the output be routed to both?  Don't know if this is relevant.
Comment 4 David Le Sage 2010-04-23 02:51:56 EDT
The whole thing just crashed.  See abrt report:

https://bugzilla.redhat.com/show_bug.cgi?id=585102

if you think that will shed light on these other problems.
Comment 5 David Le Sage 2010-04-23 02:54:35 EDT
I just restarted it.  I had two separate xterm windows and ran gnome-shell --replace in *one* of them.  As per last time, the output from running the command mirrors in *both*.   I closed the xterm in which I had not started gnome-shell and it continued to run without a problem.  As per the above, no idea if this is related to the other erratic behaviour.
Comment 6 Owen Taylor 2011-03-26 11:58:34 EDT
A lot of changes since Fedora 13 both on the X side and on the multihead handling in GNOME Shell. I'm going to assume that this has been resolved since then. These seems most like xrandr was suddenly reporting different information. (Note that in the Fedora 15 System Settings you can configure which monitor is primary in the Displays panel of System Settings by dragging the top bar between monitors.)

Note You need to log in before you can comment on or make changes to this bug.