Bug 585128 - password echoed to console
password echoed to console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
: 590925 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker 586040
  Show dependency treegraph
 
Reported: 2010-04-23 03:46 EDT by Joachim Backes
Modified: 2010-05-12 18:04 EDT (History)
11 users (show)

See Also:
Fixed In Version: initscripts-9.11-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586040 (view as bug list)
Environment:
Last Closed: 2010-05-08 07:56:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
plymouth-debug.log (3.28 KB, application/x-gzip)
2010-04-26 22:52 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2010-04-23 03:46:37 EDT
Description of problem:
Booting into runlevel 3 (with RHGB, appending ' 3' after RHGB). After 
boot is completed, goto on console #1.

0. Waiting some seconds
1. Very often, when typing the username, it is *not echoed* (but accepted)
2a. In this case, typing in the password, it is fully reflected :-(

------ this appears on console #1 -----------------
Fedora release 13 (Goddard)
Kernel 2.6.33.2-57.fc13.i686 on an i686 (tty1)

eule login: Password: testuser

[testuser@eule ~]$
------------------------  OR case 2b, username is reflected ---- 
---------------------------- and password is reflected ---------
Fedora release 13 (Goddard)
Kernel 2.6.33.2-57.fc13.i686 on an i686 (tty1)

eule login: testuser
Password:testuser
Last login: Thu Apr ........... from localhost.localdomain
------------------------------------------------------------



But: If booting into runlevel 3 *without RHGB*, or into runlevel 5, the 
described effect does not appear.



Version-Release number of selected component (if applicable):
upstart-0.6.5-3.fc13.i686

How reproducible:
Rather often

Steps to Reproduce:
1.See description
2.
3.
  
Actual results:
See description

Expected results:

The username is reflecetd, but not the password
Additional info:

My CPU is ATHLON XP 3000+, not so slow
Comment 1 Ray Strode [halfline] 2010-04-23 14:31:15 EDT
what version of plymouth?
Comment 2 Joachim Backes 2010-04-24 01:16:52 EDT
(In reply to comment #1)
> what version of plymouth?    

plymouth-0.8.2-2.fc13.i686
Comment 3 Ray Strode [halfline] 2010-04-26 10:37:33 EDT
can you add plymouth:debug to the kernel command line in grub and then attach /var/log/plymouth-debug.log

It almost sounds like the tty is started before plymouth quits fully, or plymouth is crashing.
Comment 4 Ray Strode [halfline] 2010-04-26 13:01:52 EDT
I think I may know what's happening here (although as usual, i can't reproduce myself)

/etc/init/quit-plymouth.conf has 

start on stopping rc RUNLEVEL=[234]

script
     /usr/bin/plymouth quit
end script

the job description for starting ttys (start-ttys.conf) has:

start on stopped rc RUNLEVEL=[2345]
task
script
    ... start ttys ...
end script

so in theory plymouth quit should be getting run when rc is stopping and the ttys should be getting run after rc has stopped.

One explanation for this bug, though, is plymouth quit is getting run at the same time as the ttys are getting started.

Reading through the output of "man stopping" I see:

init(8) wll wait for all services started by this event to be running [and] all tasks started by this event to have finished ... before allowing the job to continue stopping.

I think this means if quit-plymouth is a service in upstart's eyes, then it will only wait for plymouth quit to start, not finish before moving on.  If it's a task in upstart's eyes, it will properly block until plymouth quit is finished.

Note from above quit-plymouth.conf *doesn't* have the word task in it like start-ttys.conf does. Presumably that means upstart thinks quit-plymouth is a service not a task.

Can someone who sees this bug fairly reliably try adding "task" on the line before the line that says "script" in /etc/init/quit-plymouth.conf to see if that fixes this issue?
Comment 6 Joachim Backes 2010-04-26 22:52:22 EDT
Created attachment 409336 [details]
plymouth-debug.log

plymouth-debug.log
Comment 7 Fedora Update System 2010-05-03 20:26:10 EDT
initscripts-9.11-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/initscripts-9.11-1.fc13
Comment 8 Fedora Update System 2010-05-04 19:53:56 EDT
initscripts-9.11-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Gilboa Davara 2010-05-06 01:11:12 EDT
I've installed the koji initscripts and I'm no longer seeing this bug.

- Gilboa
Comment 10 Joachim Backes 2010-05-06 01:35:03 EDT
(In reply to comment #8)
> initscripts-9.11-1.fc13 has been pushed to the Fedora 13 stable repository.  If
> problems still persist, please make note of it in this bug report.    

Works not for me if booting without rhgb into runlevel 3.
Comment 11 Bill Nottingham 2010-05-06 12:16:48 EDT
Joachim - in what way does it not work? Does it make things worse, or does it just fail the same way?
Comment 12 Joachim Backes 2010-05-06 12:40:56 EDT
1. I installed this morning  * initscripts-9.11-1.fc13.i686 *

2. Booting into runlevel 3 *with* rhgb and then logging in on tty1:
   Userid is *not* echoed
   Password is *fully* echoed

   Fedora release 13 (Goddard)
   Kernel 2.6.33.3-79.fc13.i686 on an i686 (tty1)

   eule login: Password: testuser

   But this happens only on tty1, but not on tty2,...
Comment 13 Joachim Backes 2010-05-07 03:43:51 EDT
Problems persits with initscripts-9.12-1.fc13.i686.
Comment 14 Gilboa Davara 2010-05-07 11:15:35 EDT
I can't seem to be able to reproduce it.
init 3 + rhgb + serial console.
I don't see the password in the normal console or serial consoles.

P.S. It's a virtual machine.

- Gilboa
Comment 15 Adam Williamson 2010-05-07 14:16:35 EDT
I saw this bug in some of my testing of TC1, FWIW. It seems somewhat random - it doesn't _always_ happen. In my case, both login and password were echoed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Ray Strode [halfline] 2010-05-07 14:58:42 EDT
i was able to reproduce this and fixed it upstream here:

http://cgit.freedesktop.org/plymouth/commit/?id=8c390bea97ccd2c0f74f63fd90d549dd4f488651

i'll push to f13 shortly.  Note, both fixes are important (the initscripts fix and this up coming plymouth fix) to get rid of the problem.
Comment 17 Fedora Update System 2010-05-07 15:13:27 EDT
plymouth-0.8.2-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/plymouth-0.8.2-3.fc13
Comment 18 Adam Williamson 2010-05-07 16:04:19 EDT
joachim: when the initscripts package is available, could you please test this ASAP? we probably want to pull this fix in and spin an RC2, but we need to do that very fast to make our timings. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Bill Nottingham 2010-05-07 16:13:22 EDT
The fix is in http://admin.fedoraproject.org/updates/plymouth-0.8.2-3.fc13 ; the related initscripts fix is already available in the F13 branched tree.
Comment 20 Adam Williamson 2010-05-07 16:29:50 EDT
okay. I am now able to reproduce this locally, so I will test too. Ray reminds us to rebuild initrd after installing the new plymouth, with dracut.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Joachim Backes 2010-05-08 01:07:51 EDT
I updated to 

plymouth-0.8.2-3.fc13.i686.rpm
plymouth-utils-0.8.2-3.fc13.i686.rpm
plymouth-gdm-hooks-0.8.2-3.fc13.i686.rpm

from http://admin.fedoraproject.org/updates/plymouth-0.8.2-3.fc13 

but: still the userid is not echoed, and the passwod is echoed (runlevel 3, with RHGB).  :-(

Remark:

The complete plymouth stuff installed on my box is (now after the update for that 3 packages):

plymouth-graphics-libs-0.8.2-2.fc13.i686
plymouth-0.8.2-3.fc13.i686
plymouth-plugin-label-0.8.2-2.fc13.i686
plymouth-scripts-0.8.2-2.fc13.i686
plymouth-core-libs-0.8.2-2.fc13.i686
plymouth-utils-0.8.2-3.fc13.i686
plymouth-plugin-two-step-0.8.2-2.fc13.i686
plymouth-system-theme-0.8.2-2.fc13.i686
plymouth-gdm-hooks-0.8.2-3.fc13.i686
plymouth-theme-charge-0.8.2-2.fc13.i686
Comment 22 Adam Williamson 2010-05-08 07:26:37 EDT
You should update all the plymouth packages, and after installing, run 'dracut -f' to rebuild your initrd.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Joachim Backes 2010-05-08 07:56:58 EDT
Bingo!

Now seems to be OK: userid is echoed, password not.

Thankyou all for support.

Kind regards

Joachim Backes
Comment 24 Adam Williamson 2010-05-08 08:24:39 EDT
Thanks for the confirmation.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Ray Strode [halfline] 2010-05-12 18:04:07 EDT
*** Bug 590925 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.