Bug 590925 - "stty -onlcr"-looking console boot messages
"stty -onlcr"-looking console boot messages
Status: CLOSED DUPLICATE of bug 585128
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-10 20:18 EDT by Roland McGrath
Modified: 2010-05-12 18:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 18:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2010-05-10 20:18:08 EDT
Description of problem:

I'm not sure whose fault this is.  I'm using the vanilla graphical boot with default kernel args from a fresh install, and then hit ESC to see the messages.

I had done some rescue-mode fiddling and upon rebooting it was taking forever to I hit ESC to see messages and it was the "*** Warning -- SELinux ..." relabel message.  The lines following that one (three more '***" lines for that message) were stair-stepped, i.e. looking like output after "stty -onlcr".  All the lines with a green "OK" (before and after this) were terminated correctly.  Later messages (long after the end of rc.sysinit) that weren't the colorized OK or FAILED sort, also had the stair-step problem.

Version-Release number of selected component (if applicable):
initscripts-9.12-1.fc13.x86_64
plymouth-0.8.2-2.fc13.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ray Strode [halfline] 2010-05-12 18:04:07 EDT
I think this is fixed in plymouth-0.8.3-3.fc13.x86_64.  There was a bug where we weren't properly unlocking the tty on shutdown (and presumably on escape)

I'm going to close this one out, but if installing plymouth-0.8.3-3.fc13 and rebuilding your initrd (with /usr/libexec/plymouth/plymouth-update-initrd) doesn't fix the issue, then please reopen and I will investigate further.

*** This bug has been marked as a duplicate of bug 585128 ***

Note You need to log in before you can comment on or make changes to this bug.