Bug 585203 - Too high fan speed using nouveau driver - regression since F12
Summary: Too high fan speed using nouveau driver - regression since F12
Status: CLOSED DUPLICATE of bug 529973
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 12:28 UTC by Mathieu F
Modified: 2010-05-02 14:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-02 14:10:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My X.org log (53.98 KB, application/octet-stream)
2010-04-23 12:32 UTC, Mathieu F
no flags Details
My dmesg log (52.35 KB, application/octet-stream)
2010-04-23 12:33 UTC, Mathieu F
no flags Details
Xorg log (51.62 KB, text/plain)
2010-04-27 19:00 UTC, Mathieu F
no flags Details
dmesg log (45.31 KB, text/plain)
2010-04-27 19:06 UTC, Mathieu F
no flags Details
last messages log with recursive lock (5.31 KB, text/plain)
2010-04-27 19:40 UTC, Mathieu F
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 529973 None None None Never

Description Mathieu F 2010-04-23 12:28:39 UTC
Description of problem:
On my Dell XPS M1530 laptop with a nVidia 8600M GT graphic card, fan never slows down. I think it's the medium level of fanning, when F12 with nouveau or F13 and Win7 with nvidia use the lowest level. However my Core 2 Duo CPU is quite cool, i.e. less than 60°C. Even if it's 49°C, fan doesn't slow.
If I restart on Windows, the fan slows down within a minute.

Version-Release number of selected component (if applicable):
0.0.16-3.20100305git6b8b157.fc13.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot.
2. Listen to fan speed.

Actual results:
Fan speed is too high.

Expected results:
Same fan speed as on F12.

Additional info:
F12 have no problem like this with nouveau, so it's a regression.

I think it can be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=583956: when the reportee see high temperature, I see high use of graphic card without any reason, resulting in an high temperature which is not compensating by very high fan speed but medium fan speed.

Comment 1 Mathieu F 2010-04-23 12:32:56 UTC
Created attachment 408590 [details]
My X.org log

Comment 2 Mathieu F 2010-04-23 12:33:38 UTC
Created attachment 408591 [details]
My dmesg log

Comment 3 Ben Skeggs 2010-04-27 00:03:06 UTC
Nouveau doesn't touch *anything* related to fanspeed control, and uses the exact same clocks/fan speeds as are initialised by the VBIOS, so I'm not entirely sure how you're seeing a difference in speed here.

Comment 4 Mathieu F 2010-04-27 11:50:37 UTC
Thank you for your response.
I'm seeing a difference in speed thanks to the fan noise. It's totally imprecise, I know. However I'm absolutely sure that fan speed is higher with F13 Nouveau than with F12 Nouveau (and F13 nVidia).

With F12 Nouveau or F13 nVidia : lowest level and sometimes a rush.
With F13 Nouveau : always medium level.

Maybe it's not Nouveau, or maybe Nouveau uses more the GPU than before.

I will give a new try to Nouveau today.

Comment 5 Mathieu F 2010-04-27 18:34:13 UTC
New try : same problem.
I made something like 5 reboots (with and without KMS).

/var/log/messages have 2 recursive lockings, so I join it. Bugs for these are https://bugzilla.redhat.com/show_bug.cgi?id=586488 (K99cpuspeed) and https://bugzilla.redhat.com/show_bug.cgi?id=572220 (Xorg).

I join other logs too.

Comment 6 Mathieu F 2010-04-27 19:00:11 UTC
Created attachment 409553 [details]
Xorg log

Comment 7 Mathieu F 2010-04-27 19:06:39 UTC
Created attachment 409554 [details]
dmesg log

Comment 8 Mathieu F 2010-04-27 19:40:48 UTC
Created attachment 409565 [details]
last messages log with recursive lock

Really slow speed from my side, so I just send last /var/log/messages lock.

Comment 9 Luigi Pardey 2010-05-02 14:10:39 UTC
This report is the same as https://bugzilla.redhat.com/show_bug.cgi?id=529973.
However, the latter refers to Fedora 12 release. I will close this bug and update the version on the other one, you are welcome to post your issues there.

This bug has been triaged



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 529973 ***


Note You need to log in before you can comment on or make changes to this bug.