Bug 585414 - [abrt] crash in php-cli-5.3.2-1.fc12: Process /usr/bin/php was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in php-cli-5.3.2-1.fc12: Process /usr/bin/php was killed by sign...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-xdebug
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ecb7699d4ce3eb9b8bc947d2169...
: 595463 599285 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 22:56 UTC by Nathanael Noblet
Modified: 2010-09-02 20:49 UTC (History)
5 users (show)

Fixed In Version: php-pecl-xdebug-2.1.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-01 05:48:23 UTC


Attachments (Terms of Use)
File: backtrace (16.75 KB, text/plain)
2010-04-23 22:56 UTC, Nathanael Noblet
no flags Details

Description Nathanael Noblet 2010-04-23 22:56:49 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/php /home/gnat/Projects/eclipse/nedco/test/functional/nedco/callActionsTest.php
comment: Just ran some unit tests
component: php
executable: /usr/bin/php
kernel: 2.6.32.11-99.fc12.x86_64
package: php-cli-5.3.2-1.fc12
rating: 4
reason: Process /usr/bin/php was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1. Running some unit tests in a symfony framework
2.
3.

Comment 1 Nathanael Noblet 2010-04-23 22:56:51 UTC
Created attachment 408753 [details]
File: backtrace

Comment 2 Nathanael Noblet 2010-04-24 03:40:06 UTC
So I changed this to xdebug since I've had many many crashes today - ran a core dump through gdb bt and saw it was failing in xdebug. Removing it allowed the scripts to complete.

Comment 3 Nathanael Noblet 2010-04-24 03:52:03 UTC
Also - I've downloaded xdebug-2.1.0RC1.tgz, taken your original spec and used it to build the RC1 for 2.1. Once installed the scripts seem to work. So no idea what to do regarding xdebug in F12 or this bug report...

Comment 4 Remi Collet 2010-05-25 05:29:32 UTC
*** Bug 595463 has been marked as a duplicate of this bug. ***

Comment 5 Remi Collet 2010-06-03 04:59:45 UTC
*** Bug 599285 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Admin XMLRPC Client 2010-08-11 17:52:07 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 7 Fedora Update System 2010-08-11 19:26:15 UTC
php-pecl-xdebug-2.1.0-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc14

Comment 8 Fedora Update System 2010-08-11 19:26:45 UTC
php-pecl-xdebug-2.1.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc13

Comment 9 Fedora Update System 2010-08-11 19:27:12 UTC
php-pecl-xdebug-2.1.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc12

Comment 10 Fedora Update System 2010-08-12 04:07:31 UTC
php-pecl-xdebug-2.1.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-xdebug'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc12

Comment 11 Fedora Update System 2010-08-12 04:11:34 UTC
php-pecl-xdebug-2.1.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-xdebug'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc13

Comment 12 Fedora Update System 2010-08-12 19:59:50 UTC
php-pecl-xdebug-2.1.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-xdebug'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc14

Comment 13 Fedora Update System 2010-09-01 05:48:12 UTC
php-pecl-xdebug-2.1.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-09-02 20:47:33 UTC
php-pecl-xdebug-2.1.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-09-02 20:49:44 UTC
php-pecl-xdebug-2.1.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.