Bug 585422 - [abrt] crash in pinentry-gtk-0.7.6-5.fc13: Process /usr/bin/pinentry-gtk-2 was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in pinentry-gtk-0.7.6-5.fc13: Process /usr/bin/pinentry-gtk-2 wa...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pinentry   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d0c6e7c4a032b5bac03202ab397...
Keywords:
: 585546 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-23 23:20 UTC by Jonathan Smith
Modified: 2010-05-17 18:52 UTC (History)
4 users (show)

Fixed In Version: pinentry-0.8.0-2.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 07:00:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.24 KB, text/plain)
2010-04-23 23:20 UTC, Jonathan Smith
no flags Details

Description Jonathan Smith 2010-04-23 23:20:02 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/pinentry-gtk-2 --display :0.0
component: pinentry
executable: /usr/bin/pinentry-gtk-2
global_uuid: d0c6e7c4a032b5bac03202ab397238807456f523
kernel: 2.6.33.2-57.fc13.x86_64
package: pinentry-gtk-0.7.6-5.fc13
rating: 4
reason: Process /usr/bin/pinentry-gtk-2 was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Encrpyt a file named bar
2. gpg --decrypt --no-mdc-warning -o foo bar
3. crashy, crashy

Comment 1 Jonathan Smith 2010-04-23 23:20:04 UTC
Created attachment 408761 [details]
File: backtrace

Comment 2 Stanislav Ochotnicky 2010-04-26 15:15:40 UTC
Would you care to provide more information? More specifically:

1. what window manager/desktop environment are you using
2. can you reproduce repeatedly time after time?
3. do you use any special settings for gpg-agent? (for example --no-grab option)

Comment 3 Stanislav Ochotnicky 2010-04-26 15:18:50 UTC
*** Bug 585546 has been marked as a duplicate of this bug. ***

Comment 4 Jonathan Smith 2010-04-27 00:01:06 UTC
1) GNOME, except I don't use Metacity. I use Fluxbox for the WM.

2) Yes, it is 100% reproducible on my system.

3) Nope.

Comment 5 Stanislav Ochotnicky 2010-04-27 06:49:24 UTC
Well...at least I have a workaround for you. I was also able to reproduce with 100% on *box WMs. Going back to metacity would solve this issue for you. There is of course also possibility to use pinentry-qt until we can find solution to this problem with upstream. There is a fix in upstream trunk of pinentry as of now, but it would not solve your issue because problem you are experiencing is probably caused by fluxbox.

See bug 554884#c2

I would add that this means fluxbox prevents pinentry-gtk from grabbing keyboard when it's starting up. Fix in pinentry trunk will stop SIGABRT, but it will prevent you from entering pin anyway.

I will try to update pinentry soon(ish) so that we can at least prevent those ugly SIGABRTs.

Comment 6 Fedora Update System 2010-04-27 12:08:11 UTC
pinentry-0.8.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pinentry-0.8.0-1.fc12

Comment 7 Fedora Update System 2010-04-27 12:08:20 UTC
pinentry-0.8.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pinentry-0.8.0-1.fc13

Comment 8 Fedora Update System 2010-04-28 01:15:17 UTC
pinentry-0.8.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pinentry'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pinentry-0.8.0-1.fc13

Comment 9 Fedora Update System 2010-04-28 01:19:58 UTC
pinentry-0.8.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pinentry'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pinentry-0.8.0-1.fc12

Comment 10 Fedora Update System 2010-04-30 17:10:32 UTC
pinentry-0.8.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pinentry'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pinentry-0.8.0-1.fc12

Comment 11 Fedora Update System 2010-04-30 23:37:45 UTC
pinentry-0.8.0-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pinentry'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pinentry-0.8.0-2.fc13

Comment 12 Fedora Update System 2010-05-06 06:59:59 UTC
pinentry-0.8.0-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-05-10 07:52:29 UTC
pinentry-0.8.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pinentry-0.8.0-2.fc12

Comment 14 Fedora Update System 2010-05-17 18:51:39 UTC
pinentry-0.8.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.