Bug 585588 - microcode_ctl init script is broken
microcode_ctl init script is broken
Status: CLOSED DUPLICATE of bug 552246
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: microcode_ctl (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anton Arapov
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-24 18:28 EDT by Gordan Bobic
Modified: 2014-06-18 04:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 01:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordan Bobic 2010-04-24 18:28:55 EDT
Description of problem:
/etc/init.d/microcode_ctl init script is broken. It doesn't even parse. It dies with the error:
line 52: syntax error near unexpected token `}'
line 52: `}'

Version-Release number of selected component (if applicable):
microcode_ctl-1.17-1.42.1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run the /etc/init.d/microcode_ctl init script
  
Actual results:
Dies with the error:
line 52: syntax error near unexpected token `}'
line 52: `}'

Expected results:
Successful startup without parse errors.

Additional info:
Putting a "return" line in the stop() function fixes the problem.
Fedora 12 package microcode_ctl-1.17-1.57.fc12.x86_64 doesn't suffer from this problem, so installing it instead of the RHEL6b supplied one also fixes the problem.
Comment 2 RHEL Product and Program Management 2010-04-24 20:12:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Anton Arapov 2010-04-26 01:34:37 EDT
thanks for the report!

*** This bug has been marked as a duplicate of bug 552246 ***

Note You need to log in before you can comment on or make changes to this bug.