Bug 552246 - A syntax error occurs when starting microcode_ctl, and microcode isn't applied
Summary: A syntax error occurs when starting microcode_ctl, and microcode isn't applied
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: microcode_ctl
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Anton Arapov
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
: 559510 561241 563605 577965 584910 584995 585588 592105 596053 604096 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-01-04 13:28 UTC by Radek Bíba
Modified: 2018-10-27 14:51 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-24 12:40:31 UTC


Attachments (Terms of Use)

Description Radek Bíba 2010-01-04 13:28:13 UTC
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
microcode_ctl-1.17-1.42.1.el6

How reproducible:
Always, apparently.

Steps to Reproduce:
1. watch boot messages, or run service microcode_ctl start
  
Actual results:
/etc/init.d/microcode_ctl: line 52: syntax error near unexpected token `}'
/etc/init.d/microcode_ctl: line 52: `}'

And cpu microcode isn't applied (!)

Expected results:
Quiet success :)

Additional info:
The cause of the error is this:
stop()
{
}

Please remember that functions in BASH can't have an empty body. If there's no command to run for this function in this init script, it should at least execute something like `true', or it shouldn't be defined at all and the 'case' branch for 'stop' should just run `exit 0'.

Comment 1 Bill Nottingham 2010-01-28 20:59:28 UTC
*** Bug 559510 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2010-01-28 21:01:50 UTC
Bug 479898 has a fix for this. :)

Comment 3 Bill Nottingham 2010-02-03 20:28:53 UTC
*** Bug 561241 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2010-02-10 19:37:51 UTC
*** Bug 563605 has been marked as a duplicate of this bug. ***

Comment 5 Anton Arapov 2010-02-24 10:39:10 UTC
fixed in microcode_ctl-1.17-3.el6

Comment 7 Jay Turner 2010-02-24 12:14:36 UTC
Looks like the fix actually landed in 1.17-2.el6 and I've confirmed this fix resolves the issue.  Will close out once the package appears in an official compose.

Comment 8 Anton Arapov 2010-03-30 08:24:40 UTC
*** Bug 577965 has been marked as a duplicate of this bug. ***

Comment 9 Anton Arapov 2010-04-23 07:25:59 UTC
*** Bug 584995 has been marked as a duplicate of this bug. ***

Comment 10 Bill Nottingham 2010-04-23 20:02:51 UTC
*** Bug 584910 has been marked as a duplicate of this bug. ***

Comment 11 Anton Arapov 2010-04-26 05:34:37 UTC
*** Bug 585588 has been marked as a duplicate of this bug. ***

Comment 12 Bill Nottingham 2010-05-13 21:31:54 UTC
*** Bug 592105 has been marked as a duplicate of this bug. ***

Comment 15 Anton Arapov 2010-05-26 09:30:27 UTC
*** Bug 596053 has been marked as a duplicate of this bug. ***

Comment 16 Anton Arapov 2010-06-15 12:48:09 UTC
*** Bug 604096 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.