Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 585645 - virt-image --help ouput broken ?
virt-image --help ouput broken ?
Status: CLOSED DUPLICATE of bug 582748
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 07:08 EDT by Carl G.
Modified: 2010-04-26 10:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 10:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl G. 2010-04-25 07:08:54 EDT
Description of problem:

Virt-image produce an ugly output :

[carl@XX ~]$ virt-image --help
show program's version number and exit
show this help message and exit
Connect to hypervisor with URI
Name of the guest instance
Memory to allocate for guest instance in megabytes
UUID for the guest.
Number of vcpus to configure for your guest
Check that vcpus do not exceed physical CPUs and warn
if they do.
Set which physical CPUs Domain can use.
The OS type being installed, e.g. 'linux', 'unix',
'windows'
The OS variant being installed, e.g. 'fedora6',
'rhel5', 'solaris10', 'win2k'
Disables APIC for fully virtualized guest
Disables ACPI for fully virtualized guest
Specify a network interface. Ex:
--network bridge=mybr0
--network network=libvirt_network_name
--network network=mynet,model=e1000,mac=00:11...
Use VNC for graphics support
Port to use for VNC
Address to listen on for VNC connections.
set up keymap for the VNC console
Use SDL for graphics support
Don't set up a graphical console for the guest.
Print the libvirt XML, but do not start the domain
The zero-based index of the boot record to use
Overwrite, or destroy, an existing image with the same
name
Skip disk checksum verification process
Print debugging information
Do not prompt for input. Answers yes where applicable,
terminates for all other prompts
Usage: virt-image [options] image.xml

Options:
  --version             show program's version number and exit
  -h, --help            show this help message and exit
  --connect=CONNECT     Connect to hypervisor with URI
...


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Open a terminal
2.Type : virt-image --help
  
Actual results:

See above

Expected results:

Mhm..

Additional info:

On F13 w. the latest updates (repo : testing-updates)?.
Comment 1 Cole Robinson 2010-04-26 10:05:43 EDT

*** This bug has been marked as a duplicate of bug 582748 ***

Note You need to log in before you can comment on or make changes to this bug.