Bug 582748 - virt-install --help has a lot of extraneous noise
Summary: virt-install --help has a lot of extraneous noise
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-virtinst
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 585645 590013 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-15 17:50 UTC by Bill Nottingham
Modified: 2014-03-17 03:23 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-06-16 17:42:42 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2010-04-15 17:50:04 UTC
Description of problem:

[notting@nostromo: ~]$ virt-install  --help
show program's version number and exit
show this help message and exit
Connect to hypervisor with URI
Name of the guest instance
Memory to allocate for guest instance in megabytes
The CPU architecture to simulate
UUID for the guest.
Number of vcpus to configure for your guest
Check that vcpus do not exceed physical CPUs and warn
if they do.
Set which physical CPUs Domain can use.
The OS type for fully virtualized guests, e.g.
'linux', 'unix', 'windows'
The OS variant for fully virtualized guests, e.g.
'fedora6', 'rhel5', 'solaris10', 'win2k'
Add a serial device to the domain.
Add a parallel device to the domain.
Physical host device to attach to the domain.
Use sound device emulation
Disables APIC for fully virtualized guest (overrides
value in os-type/os-variant db)
Disables ACPI for fully virtualized guest (overrides
value in os-type/os-variant db)
This guest should be a fully virtualized guest
This guest should be a paravirtualized guest
Hypervisor name to use (kvm, qemu, xen, ...)
CD-ROM installation media
Installation source (eg, nfs:host:/path,
http://host/path, ftp://host/path)
Boot from the network using the PXE protocol
Build guest around an existing disk image
Treat the CD-ROM media as a Live CD
Additional arguments to pass to the kernel booted from
--location
Specify storage with various options. Ex.
--disk path=/my/existing/disk
--disk path=/my/new/disk,size=5 (in gigabytes)
--disk vol=poolname:volname,device=cdrom,bus=scsi,...
Don't set up any disks for the guest.
Specify a network interface. Ex:
--network bridge=mybr0
--network network=my_libvirt_virtual_net
--network network=mynet,model=virtio,mac=00:11...
Don't create network interfaces for the guest.
Use VNC for graphics support
Port to use for VNC
Address to listen on for VNC connections.
set up keymap for the VNC console
Use SDL for graphics support
Don't set up a graphical console for the guest.
Specify video hardware type.
Don't automatically try to connect to the guest
console
Print debugging information
Have domain autostart on host boot up.
Disables the automatic rebooting when the installation
is complete.
Time to wait (in minutes)
Forces 'yes' for any applicable prompts, terminates
for all others
Request user input for ambiguous situations or
required options.
Usage: virt-install --name NAME --ram RAM STORAGE INSTALL [options]

Options:
  --version             show program's version number and exit
  -h, --help            show this help message and exit
  --connect=CONNECT     Connect to hypervisor with URI

  General Options:
...

Version-Release number of selected component (if applicable):

python-virtinst-0.500.2-3.fc13.noarch

How reproducible:

100%

Comment 1 Cole Robinson 2010-04-15 18:40:17 UTC
Fix available upstream:

http://hg.fedorahosted.org/hg/python-virtinst/rev/ea001987710b

Comment 2 Cole Robinson 2010-04-26 14:05:43 UTC
*** Bug 585645 has been marked as a duplicate of this bug. ***

Comment 3 Cole Robinson 2010-05-07 14:37:38 UTC
*** Bug 590013 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2010-05-27 20:44:12 UTC
python-virtinst-0.500.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-virtinst-0.500.3-1.fc13

Comment 5 Fedora Update System 2010-05-28 18:00:36 UTC
python-virtinst-0.500.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-virtinst-0.500.3-1.fc13

Comment 6 Fedora Update System 2010-06-16 17:42:37 UTC
python-virtinst-0.500.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.