Bug 585661 - Deluge requires libboost_python-mt.so.5
Deluge requires libboost_python-mt.so.5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
: 586110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-25 09:27 EDT by seventhguardian
Modified: 2010-05-02 07:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-02 07:19:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description seventhguardian 2010-04-25 09:27:38 EDT
Description of problem:

Deluge requires on libboost_python-mt.so.5, but the latest libboost_python library is /usr/lib/libboost_python-mt.so.1.41.0.

Version-Release number of selected component (if applicable):
deluge-1.2.0-1.fc13.noarch
boost-python-1.41.0-7.fc13.i686

Steps to Reproduce:
1. Try to run "deluged -d"
  
Actual results:
It fails with:
$ deluged -d
[ERROR   ] 14:22:00 main:216 libboost_python-mt.so.5: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/deluge/main.py", line 209, in start_daemon
    Daemon(options, args)
  File "/usr/lib/python2.6/site-packages/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib/python2.6/site-packages/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib/python2.6/site-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
ImportError: libboost_python-mt.so.5: cannot open shared object file: No such file or directory
Comment 1 seventhguardian 2010-05-01 16:25:05 EDT
Setting severity as "high", since this prevents deluge from working at all.
Comment 2 seventhguardian 2010-05-01 16:27:33 EDT
*** Bug 586110 has been marked as a duplicate of this bug. ***
Comment 3 seventhguardian 2010-05-02 07:19:47 EDT
As it turns out, this is caused by f12 rpms still laying around, namely rb_libtorrent and rb_libtorrent-python. Issuing a "package-cleanup --problems" should point those out.

Fixing this was a matter of "yum downgrade rb_libtorrent", which removes deluge as a side-effect, and then "yum install deluge".

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.