Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 585839 - Fail to install on a software RAID + LVM setup
Fail to install on a software RAID + LVM setup
Status: CLOSED DUPLICATE of bug 584384
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 04:10 EDT by Mathieu Baudier
Modified: 2018-06-04 18:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 05:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mdadm and vgdisplay output from CentOS 5.4 on the same machine (13.84 KB, text/plain)
2010-04-26 04:10 EDT, Mathieu Baudier
no flags Details
Logs under /tmp (122.98 KB, application/x-gzip)
2010-04-29 17:58 EDT, Mathieu Baudier
no flags Details
kill -USR2 `cat /var/run/anaconda.pid` tb output (603.93 KB, text/plain)
2010-04-29 17:59 EDT, Mathieu Baudier
no flags Details

  None (edit)
Description Mathieu Baudier 2010-04-26 04:10:34 EDT
Created attachment 409102 [details]
mdadm and vgdisplay output from CentOS 5.4 on the same machine

Description of problem:

The x8664 DVD graphical installer hangs before the custom partitioning.

The following happens on a software development desktop (x86_64, Intel Quad-Core, 4GB memory). 
This machine is mostly used, and works perfectly, with an up to date CentOS 5.4 x86_64. 
It is also used to test many distributions and recent Fedora and Ubuntu versions also run properly on it (Ubuntu not installed on LVM).

The disk setup is a bit particular:
- 4 identical 500 GB SATA disks
- each disk is precisely sliced as follow:
  - 20 GB left free at the beginning
  - 230 GB for software RAID 5 (3 active + 1 spare) /dev/md0
  - 250 GB for software RAID 0 (4 active) /dev/md1
- 2 LVM volume groups on the RAID devices
  - vg_alma_safe on the RAID 5 /dev/md0
  - vg_alma_fast on the RAID 0 /dev/md1
(the names of the VGs say all about the rationale behind this development setup)

In general the OSes are installed on the "safe" VG and the virtual machines or data intensive operations (build, GIS, etc.) on the "fast" VG.

When trying to install RHEL 6 Beta, the following happens:
- the first disk discovery takes a lot of time
- it finally finds the 4 physical disk (I then selected them all), but with a weird message like "LogVol00 not found", which is surprising since this is not how the VGs are named
- it then goes further with the installation, but when choosing "Custom Partioning" it hangs and one needs to restart the machine


Version-Release number of selected component (if applicable):

RHEL 6 Beta 100414


How reproducible:

Always on this particular disk setup


Steps to Reproduce:

Maybe
1. Create a similar setup (free space + RAID 5 + RAID 0 on  4disks)
2. Try to install RHEL 6 on it
  

Actual results:

Installer hangs at custom partitioning


Expected results:

Installer should proceed to custom partitioning


Additional info:

I know that it may be hard to reproduce on other setup but there may be some more general problems behind this. 
I'll be happy to help and gather more information if you can point me how to proceed.
Comment 1 Hans de Goede 2010-04-26 04:21:05 EDT
Hi,

Thx for the report. Please try to install again and when the installer hangs switch to tty2 (ctrl + alt + F2) and collect the log files under /tmp, ie:
do:
tar cvfz logs.tgz /tmp/*log

Note *log not *.log we also want the syslog file.

Then copy the logs out of the installer environment (you use scp for example) and attach then here.

Once you have the logs of the machine, you can also try to do the following on tty2:
-press arrow up, this should give you the following command from the 
 pre-populated bash history:
kill -USR2 `cat /var/run/anaconda.pid`
-execute this command (press enter), this should give you a file with "tb" in
 the name under /tmp, please also attach that here.

Thanks,

Hans
Comment 3 RHEL Product and Program Management 2010-04-26 05:15:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Mathieu Baudier 2010-04-29 17:58:10 EDT
Created attachment 410242 [details]
Logs under /tmp
Comment 5 Mathieu Baudier 2010-04-29 17:59:44 EDT
Created attachment 410243 [details]
kill -USR2 `cat /var/run/anaconda.pid` tb output
Comment 6 Mathieu Baudier 2010-04-29 18:02:57 EDT
(In reply to comment #1)

The requested files are attached.

Note: I needed to execute:

ifconfig eth0

in order to be able to list this network interface and then gain access to the network (with DHCP) so that I could scp the files.
Comment 7 Hans de Goede 2010-04-30 05:10:07 EDT
Mathieu,

Thanks for the logs, looking at your syslog it seems that there are some issues with accessing your floppy drive. Most likely you do not have one, but still we see one. This is being tracked in bug 584384.

Looking at the backtrace you did, the error-ing out for the floppy drive was done by the time you did the kill -USR2. So you should be able to install with some patience.

What often helps is making sure the floppy type is set to none in your BIOS standard CMOS setup, and if you have a separate floppy controller option somewhere in the BIOS, set that to disabled.

*** This bug has been marked as a duplicate of bug 584384 ***
Comment 8 Mathieu Baudier 2010-05-01 03:13:37 EDT
Yes, I confirm that deactivating all floppy related options in BIOS much fasten the process and allows to go further.

However the installation crash later when formatting a new logical volume for the RHEL root (reported in bug #587859)

One last note: I noticed that the weird error message which is displayed in a popup at the very beginning ("LogVol00 not found" or something like that, could not copy/paste it somewhere) may have the following cause:

I test quite a few KVM based virtual machines on this system and usually create their disks as logical volumes on this host machine.
When I finally could reach the custom partitioning screen I noticed that one of the logical volume was shown as having an LVM partition type (instead of say ext3). To be frank I don't really remember my config for this particular VM but I had used the default naming conventions (with LogVol00 etc.) for its partitioning scheme.

So, in other words, the installer seems to complain if it finds some logical volumes which are themselves formatted as LVM partitions (for use in virtualized guests)
=> it then suggests to reinitialize all or to ignore (what I did)
Please tell me if it would be useful that I book a dedicated ticket for that.

Note You need to log in before you can comment on or make changes to this bug.