Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 587859 - Installation crashes when formatting newly created logical volume
Installation crashes when formatting newly created logical volume
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
: 587858 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 03:06 EDT by Mathieu Baudier
Modified: 2012-05-19 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.21.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 08:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump generated by the installer after crashing (137.49 KB, application/x-gzip)
2010-05-01 03:06 EDT, Mathieu Baudier
no flags Details

  None (edit)
Description Mathieu Baudier 2010-05-01 03:06:41 EDT
Created attachment 410645 [details]
Dump generated by the installer after crashing

Description of problem:

After doing a custom partitioning in order to install RHEL 6 beta on an existing volume group, anaconda crashes when formatting a new logical volume (lv_rhel in vg_alma_safe)

Version-Release number of selected component (if applicable):

RHEL 6 Beta 20100414

How reproducible:

I guess this would always happen again but I am not extremely keen to try and try again if there are issues at LVM level, because I have quite a lot of data on this development computer that would be painful to lose.

Steps to Reproduce:
1. with the settings described in bug #585839
2. perform a custom partitioning with an ext3 /boot partition on a primary partition of one of the disks and a / partition on a new logical volume (lv_rhel) on a software RAID5 based volume group (vg_alma_safe)  
  
Actual results:

Installation crashes

Expected results:

Installation should proceed

Additional info:

Anaconda dump generated by the installer attached
Comment 2 RHEL Product and Program Management 2010-05-01 04:15:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lumens 2010-05-01 20:39:47 EDT
*** Bug 587858 has been marked as a duplicate of this bug. ***
Comment 4 Brian Lane 2010-05-03 19:10:37 EDT
Could not reproduce this with the 20100428 nightly DVD.
Comment 7 Alexander Todorov 2010-05-13 08:02:30 EDT
With RHEL6.0-20100511.3:

I've installed using the steps to reproduce from comment #0 (virtual system, 4 disks, same partitioning but with smaller disk sizes) and install completed successfully. Wrt comment #4 I'll close this.
Comment 8 Mathieu Baudier 2010-07-03 07:06:02 EDT
I confirm that I could install RHEL 6 Beta 2 without problem on this hardware settings (writing this from the freshly installed system).

Thanks for your efforts.

Note You need to log in before you can comment on or make changes to this bug.