Bug 585858 - redhat-lsb-graphics broken
Summary: redhat-lsb-graphics broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mash
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 603304 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-26 09:28 UTC by Pierre Ossman
Modified: 2014-03-17 03:23 UTC (History)
7 users (show)

Fixed In Version: mash-0.5.20-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-13 05:58:04 UTC


Attachments (Terms of Use)

Description Pierre Ossman 2010-04-26 09:28:49 UTC
Two bugs here in redhat-lsb-graphics.

Bug 1:

rpm -q --requires -p redhat-lsb-graphics-4.0-2.fc13.x86_64.rpm 
warning: redhat-lsb-graphics-4.0-2.fc13.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID e8e40fde
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
rpmlib(PayloadIsXz) <= 5.2-1

i.e. no deps (not sure where they went as the spec file looks fine.

Bug 2:

No 32-bit package for x86_64. Obviously needed as 32-bit compatibility isn't just for console applications.

Comment 1 Parag Nemade 2010-06-24 10:01:06 UTC
*** Bug 603304 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2010-06-25 04:55:30 UTC
redhat-lsb-4.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/redhat-lsb-4.0-3.fc12

Comment 3 Fedora Update System 2010-06-25 04:56:15 UTC
redhat-lsb-4.0-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/redhat-lsb-4.0-3.fc13

Comment 4 Fedora Update System 2010-06-25 18:12:55 UTC
redhat-lsb-4.0-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update redhat-lsb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/redhat-lsb-4.0-4.fc12

Comment 5 Fedora Update System 2010-06-25 18:19:32 UTC
redhat-lsb-4.0-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update redhat-lsb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/redhat-lsb-4.0-4.fc13

Comment 6 Fedora Update System 2010-07-13 07:34:16 UTC
redhat-lsb-4.0-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update redhat-lsb'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/redhat-lsb-4.0-5.fc13

Comment 7 Parag Nemade 2010-07-15 06:25:56 UTC
notting,
  Is it Ok in this package redhat-lsb to keep its subpackages -graphics and -printing as arch packages? But then reporter here asking why not these 32-bit sub-packages available in 64-bit repo?

reporter asked in above bodhi link.

Comment 8 Bill Nottingham 2010-07-15 16:19:44 UTC
Automatic inclusion as multilib depends on the files in the package meeting certain criteria. The files in redhat-lsb-* (such as they are) don't do that... we'd need a whitelist of some sort in the compose tool.

Comment 9 Parag Nemade 2010-07-26 06:10:52 UTC
Bodhi forgot to close this

Comment 10 Fedora Update System 2010-08-05 23:38:19 UTC
redhat-lsb-4.0-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Pierre Ossman 2010-08-19 12:00:25 UTC
This bug still has unresolved bits in that 32-bit packages are missing. Reopening.

Comment 12 Parag Nemade 2010-08-19 12:23:11 UTC
What do you need here to be fixed?

What I can see in 64 bit package repo is
 redhat-lsb-4.0-5.fc13.i686.rpm 12-Jul-2010 18:43  25K   
 redhat-lsb-4.0-5.fc13.x86_64.rpm 12-Jul-2010 18:41  25K   
 redhat-lsb-graphics-4.0-5.fc13.x86_64.rpm 12-Jul-2010 18:40  12K   
 redhat-lsb-printing-4.0-5.fc13.x86_64.rpm 12-Jul-2010 18:43  11K 

main package installs some files which are really arch specific so multilib is applied there and you can see redhat-lsb's 32 and 64 bit rpms in repo. But other two subpackages provides zero length files so how can multilib be applied there?

Otherthing can be made here is to make those subpackages as noarch packages. so this issue will automatically be fixed.

Comment 13 Pierre Ossman 2010-08-19 12:33:53 UTC
The "feature" those packages provide are not files, but their set of requirements. And as those requirements are arch dependent, you need to multilib them like everything else that is specific to one arch.

The problem is that if I want to install a 32-bit, graphical, LSB compliant program on Fedora, I have to figure out which libs it need. The fact that it is LSB compliant should be sufficient though and I should be able to do "yum install redhat-lsb-graphics.i686" and run the program.

Comment 14 Pierre Ossman 2010-08-19 12:36:34 UTC
One should also note that this is a regression as this problem did not exist before the split of redhat-lsb into subpackages.

Comment 15 Parag Nemade 2010-08-19 13:01:03 UTC
notting ping again
    What and where can this be fixed in compose tool? Can a noarch package pulls arch dependent dependencies using %{_isa}?

Comment 16 Bill Nottingham 2010-08-19 20:02:51 UTC
a) %{_isa} doesn't work in noarch, afaik
b) even if it did, you wouldn't want noarch to pull in both arches

Assigning to mash, this will have to be hacked on the compose side.

Comment 17 Pierre Ossman 2010-08-20 08:49:57 UTC
You guys might be talking about arch in some other context, but none of the lsb packages are marked as noarch in the actual .rpm. If you look at comment 12 they are all x86_64 or i686.

I also noticed that there is a slight difference in which files are in the graphics sub package as it puts files in /etc/lsb-release.d that includes an arch dependent suffix.

Comment 18 Parag Nemade 2010-08-20 09:10:15 UTC
(In reply to comment #17)
> You guys might be talking about arch in some other context, but none of the lsb
> packages are marked as noarch in the actual .rpm. If you look at comment 12
> they are all x86_64 or i686.
 
 Yes. you are correct. compose side changes will give you 32 bit arch packages available in 64 bit arch repository.

> 
> I also noticed that there is a slight difference in which files are in the
> graphics sub package as it puts files in /etc/lsb-release.d that includes an
> arch dependent suffix.

Do you see any problem there? arch dependent files are installed by redhat-lsb-graphics.i686 and redhat-lsb-graphics.x86_64

Comment 19 Pierre Ossman 2010-08-20 09:18:16 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > 
> > I also noticed that there is a slight difference in which files are in the
> > graphics sub package as it puts files in /etc/lsb-release.d that includes an
> > arch dependent suffix.
> 
> Do you see any problem there? arch dependent files are installed by
> redhat-lsb-graphics.i686 and redhat-lsb-graphics.x86_64

Nah, my point was really that there are different files and not just different requirement lists as I stated in comment 13. In case that fact makes it easier to get the build system to do the right thing.

Comment 20 Bill Nottingham 2010-09-24 18:41:28 UTC
http://git.fedorahosted.org/git/?p=mash;a=commitdiff;h=262fb0e5d07290f3abdeb8ae7e52a2f9506d3010

Will be in mash-0.5.20; this will take a while to percolate out into the buildsystem itself.

Comment 21 Pierre Ossman 2010-09-27 07:42:53 UTC
Roughly how long "a while"? I suspect redhat-lsb isn't rebuilt very often, so it will probably need some manual intervention once mash is updated.

Comment 22 Bill Nottingham 2010-09-27 16:54:10 UTC
It will need built, will need to pass tests, and will need to be installed on the updates-composing boxes.

Comment 23 Fedora Update System 2010-09-28 16:17:45 UTC
mash-0.5.20-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mash-0.5.20-1.el5

Comment 24 Fedora Update System 2010-09-28 16:21:59 UTC
mash-0.5.20-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mash-0.5.20-1.fc14

Comment 25 Fedora Update System 2010-09-28 16:33:27 UTC
mash-0.5.20-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mash-0.5.20-1.fc13

Comment 26 Fedora Update System 2010-09-28 17:31:51 UTC
mash-0.5.20-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mash'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mash-0.5.20-1.fc14

Comment 27 Pierre Ossman 2010-09-29 07:36:08 UTC
Thanks for the fix! Should I add a new bug requesting a rebuild of redhat-lsb though? Or will you sort that out before closing this bug?

And do you [Red Hat] guys use mash for RHEL as well? RHEL 6 suffers from the same bug, so I'm wondering if this means that it will be solved there as well.

Comment 28 Bill Nottingham 2010-09-29 15:27:03 UTC
(In reply to comment #27)
> Thanks for the fix! Should I add a new bug requesting a rebuild of redhat-lsb
> though? Or will you sort that out before closing this bug?

I'll try and remember to prompt them once it's live.

> And do you [Red Hat] guys use mash for RHEL as well? RHEL 6 suffers from the
> same bug, so I'm wondering if this means that it will be solved there as well.

Not exactly; you'd want to file a separate issue there.

Comment 29 Fedora Update System 2010-10-13 05:56:08 UTC
mash-0.5.20-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Fedora Update System 2010-10-13 12:49:08 UTC
mash-0.5.20-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 31 Pierre Ossman 2010-10-26 13:59:14 UTC
The new system seems to be live as Fedora 14 seem to have proper packages. Fedora 13 still lacks them, so if someone could just schedule a rebuild of redhat-lsb. :)

Comment 32 Fedora Update System 2011-04-14 20:57:59 UTC
mash-0.5.20-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.