This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 585930 - vnc totally inop in F13
vnc totally inop in F13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 585895 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 09:20 EDT by Eric Frey
Modified: 2013-04-30 19:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: tigervnc-1.0.90-0.11.20100420svn4030.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 17:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Frey 2010-04-26 09:20:20 EDT
Description of problem:

Hitting any key on a tightvnc session connected to :40.0 causes immediate termination of the Xvnc process, with no apparent logging information in the system or the .vnc logs.  System running under VMWare 7.1 Beta, Win 7 host system.

Viewer is RealVNC Personal Edition VNC Viewer 4.4.3(r16583).

F13 kept up to date with test updates on a daily basis.

Version-Release number of selected component (if applicable):

Occurred when I put in the 
Apr 23 07:11:14 Updated: tigervnc-server-1.0.90-0.9.20100420svn4030.fc13.x86_64
Apr 23 07:11:17 Updated: tigervnc-1.0.90-0.9.20100420svn4030.fc13.x86_64
Apr 23 07:11:17 Updated: tigervnc-server-module-1.0.90-0.9.20100420svn4030.fc13.x86_64



How reproducible:

Steps to Reproduce:
1. Start vnc session with:
    vncserver -geometry 2000x1400 -depth 24 :40
2. connect vnc viewer to session; starts up OK. 
3. Hit any key.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Tkac 2010-04-26 11:01:13 EDT
*** Bug 585895 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2010-04-26 11:08:01 EDT
This seems like an issue with gcc, not sure yet. As a workaround let's build sources with "-fno-omit-frame-pointer", Xvnc seems fine when built with that option. Sorry for troubles.
Comment 3 Fedora Update System 2010-04-26 11:23:02 EDT
tigervnc-1.0.90-0.10.20100420svn4030.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.10.20100420svn4030.fc13
Comment 4 Paul W. Frields 2010-04-26 20:38:16 EDT
The new package appears to fix the problem for me (was bug 585895).
Comment 5 Fedora Update System 2010-04-27 01:50:01 EDT
tigervnc-1.0.90-0.10.20100420svn4030.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.10.20100420svn4030.fc13
Comment 6 Fedora Update System 2010-05-13 06:49:52 EDT
tigervnc-1.0.90-0.11.20100420svn4030.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.11.20100420svn4030.fc13
Comment 7 Fedora Update System 2010-05-13 15:27:38 EDT
tigervnc-1.0.90-0.11.20100420svn4030.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.11.20100420svn4030.fc13
Comment 8 Fedora Update System 2010-05-18 17:52:28 EDT
tigervnc-1.0.90-0.11.20100420svn4030.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.