Bug 585934 - SELinux is preventing /usr/sbin/abrtd "unlink" access on sosreport-dhcp-30-37-20100426135838-34fb.tar.bz2.
SELinux is preventing /usr/sbin/abrtd "unlink" access on sosreport-dhcp-30-37...
Status: CLOSED DUPLICATE of bug 585933
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:6fc0dc55d0a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 09:37 EDT by Eduard Benes
Modified: 2011-04-30 19:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-26 10:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduard Benes 2010-04-26 09:37:34 EDT
Summary:

SELinux is preventing /usr/sbin/abrtd "unlink" access on
sosreport-dhcp-30-37-20100426135838-34fb.tar.bz2.

Detailed Description:

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:sosreport_tmp_t:s0
Target Objects                sosreport-dhcp-30-37-20100426135838-34fb.tar.bz2 [
                              file ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-1.0.7-5.el6
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.17-5.el6
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.32-19.el6.i686
                              #1 SMP Tue Mar 9 18:10:40 EST 2010 i686 i686
Alert Count                   1
First Seen                    Mon 26 Apr 2010 01:58:39 PM CEST
Last Seen                     Mon 26 Apr 2010 01:58:39 PM CEST
Local ID                      f42d6687-0ec6-4eb9-b60b-225fadfa4a0c
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272283119.63:23031): avc:  denied  { unlink } for  pid=1653 comm="abrtd" name="sosreport-dhcp-30-37-20100426135838-34fb.tar.bz2" dev=dm-0 ino=258866 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sosreport_tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1272283119.63:23031): arch=40000003 syscall=10 success=no exit=-13 a0=84a652c a1=ffffffff a2=376734 a3=806a510 items=0 ppid=1 pid=1653 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.7.17-5.el6,catchall,abrtd,abrt_t,sosreport_tmp_t,file,unlink
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t sosreport_tmp_t:file unlink;
Comment 1 Daniel Walsh 2010-04-26 10:10:07 EDT

*** This bug has been marked as a duplicate of bug 585933 ***

Note You need to log in before you can comment on or make changes to this bug.