Bug 585953 - system-config-authentication generates invalid config file
Summary: system-config-authentication generates invalid config file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
: 588372 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-26 14:20 UTC by Chris Hodson
Modified: 2018-09-05 13:56 UTC (History)
5 users (show)

Fixed In Version: authconfig-6.1.4-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 19:55:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chris Hodson 2010-04-26 14:20:49 UTC
Description of problem:
Running system-config-authentication generates a config file that generates the following error:
nslcd: /etc/nslcd.conf:135: unknown keyword: 'pam_password'

Version-Release number of selected component (if applicable):
6.0 Beta

How reproducible:
Every Time

Steps to Reproduce:
1. system-config-authentication
2. Check "LDAP support" for both User Information and Authentication
3. Exit

When the config script exits it tries to restart nslcd and the error message comes up.

Comment 2 RHEL Program Management 2010-04-26 15:14:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Chris Carpenter 2010-04-30 13:23:17 UTC
I just wanted to say that this bug is also affecting me on RHEL 6.0 beta. 

However, if I run system-config-authentication, then comment out the pam_password md5 line and disable TLS authentication, I can connect to the LDAP server.

Comment 4 Tomas Mraz 2010-05-03 15:44:19 UTC
*** Bug 588372 has been marked as a duplicate of this bug. ***

Comment 8 releng-rhel@redhat.com 2010-11-10 19:55:12 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.