Bug 588372 - authconfig --enableldap writes /etc/nslcd.conf not accepted by nslcd
authconfig --enableldap writes /etc/nslcd.conf not accepted by nslcd
Status: CLOSED DUPLICATE of bug 585953
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: authconfig (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Tomas Mraz
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 11:18 EDT by Stephan Wiesand
Modified: 2010-05-03 11:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 11:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephan Wiesand 2010-05-03 11:18:50 EDT
Description of problem:

The configuration written during kickstart installation with "authconfig --enableldap" is rejected by nslcd. It complains about the last line, "pam_password md5". Commenting this line makes it work.

No big deal of course.

How reproducible: 100%

Steps to Reproduce:
1. Kickstart RHEL6 public beta with a line like

authconfig --useshadow  --enableldap --ldapserver w.x.y.z --ldapbasedn dc=X,dc=Y --enablekrb5 --krb5realm XYZ.DE --krb5kdc kdc1.xyz.de --krb5adminserver kdc1.xyz.de

2. After installation, run "service nslcd status; service nslcd start"
  
Actual results:

# service nslcd status
nslcd is stopped
# service nslcd start
Starting nslcd: nslcd: /etc/nslcd.conf:135: unknown keyword: 'pam_password'
                                                           [FAILED]

Expected results:

#service nslcd status
nslcd (pid  6623) is running...
# service nslcd restart
Stopping nslcd:                                            [  OK  ]
Starting nslcd:                                            [  OK  ]
Comment 1 Tomas Mraz 2010-05-03 11:44:19 EDT

*** This bug has been marked as a duplicate of bug 585953 ***

Note You need to log in before you can comment on or make changes to this bug.