Bug 585965 - Incorrect Errata calculation/Update for multi-lib systems
Incorrect Errata calculation/Update for multi-lib systems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Michael Mráka
Jan Hutař
:
: 566029 605242 (view as bug list)
Depends On:
Blocks: sat540-blockers 605242
  Show dependency treegraph
 
Reported: 2010-04-26 10:33 EDT by Vishal Gaikwad
Modified: 2011-01-28 10:04 EST (History)
9 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 605242 (view as bug list)
Environment:
Last Closed: 2010-10-28 10:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Schema upgrade script (3.52 KB, application/octet-stream)
2010-06-02 11:52 EDT, Justin Sherrill
no flags Details

  None (edit)
Description Vishal Gaikwad 2010-04-26 10:33:05 EDT
Description of problem:
The option to upgrade existing packages from satellite web interface i.e System Profile -> Software -> Packages -> Upgrade this doesn't work as expected for x86_64 systems.

If i386 and x86_64 package is installed on the system with one being latest and other slightly old - still the older one wouldn't be listed as available for upgrade under the system profile.

Version-Release number of selected component (if applicable):
RHNS 530

How reproducible:
Always

Steps to Reproduce:
1. WebUI -> Systems
2. Select a x86_64 system
3. Software -> Upgrade
4. Make sure you are a list of package for both the arch available in the list
5. Select the i386 package only and update.
6. Repeat steps 1-3 and you will see that now it doesn't list the x86_64 package
  
Actual results:
Upgrade list doesnt show x86_64 package as available

Expected results:
It should show the package that was not upgraded

Additional info:
Reproduced locally on RHNS 530. It seems that entries for both the packages are removed from the cache when only one arch of the package is updated.
Comment 2 Justin Sherrill 2010-05-20 11:30:37 EDT
Ok,

I think i have this figured out and fixed.  The downside is that is requires a schema change in addition to a java side change.

Commit:

7ff5c9d737d679513732e0b570e3ed8b5147aaed


Basically the query was not taking into consideration arch information on what was already installed.  I changed it to take this into consideration and restrict by the Arch but this also caused an issue.  

firstboot-tui's arch actually change during the RHEL 5 lifecycle, so it started off as a noarch package and became an x86_64 package.  So i had to restrict by arch only when it was relevant.  

It's amazing how confusing such a simple little thing can become....
Comment 4 Justin Sherrill 2010-06-02 11:52:15 EDT
Created attachment 419082 [details]
Schema upgrade script

Attaching schema-fix-585965.sql
Comment 13 Michael Mráka 2010-09-03 06:02:53 EDT
FAILS_QA

channel rhel5 x86_64 on server contains:
openldap-2.3.43-12.el5_5.2.i386
openldap-2.3.43-12.el5_5.2.x86_64
openssl-0.9.8e-12.el5_4.6.i386
openssl-0.9.8e-12.el5_4.6.x86_64

rhel5  x86_64 client has:
openldap-2.3.43-12.el5_5.1.i386
openldap-2.3.43-12.el5_5.2.x86_64
openssl-0.9.8e-12.el5_4.1.i386
openssl-0.9.8e-12.el5_4.1.x86_64

yum on client shows:
 openldap                x86_64 2.3.43-12.el5_5.2            rhel-x86_64-server-5 303 k
 openssl                 i686   0.9.8e-12.el5_4.6            rhel-x86_64-server-5 1.4 M
 openssl                 x86_64 0.9.8e-12.el5_4.6            rhel-x86_64-server-5 1.4 M

webUI shows:
<nothing>
Comment 15 Michael Mráka 2010-09-06 07:45:48 EDT
Fixed in upstream by
commit 6e717160dcddef1225f18af6b98d96b9a625888d
    585965 - rhnServerNeededView rewritten from scratch
    
    it utilize rhnChannelNewestPackage cache table and new table for package upgrade
    compatibility
commit d02a5eec45b0b0283770dcf88e6141f4caed37a0
    rhnPackageUpgradeArchCompat - an <package_arch> package can be upgraded by newer <package_upgrade_arch> package
Comment 16 Michael Mráka 2010-09-13 03:36:41 EDT
Fixed in 'spacewalk-backend-1.2.10-1'. 'spacewalk-backend-1.2.11-1.el5sat'
included in compose 'Satellite-5.4.0-RHEL5-re20100910.2'.
Moving to ON_QA.
Comment 17 Jan Hutař 2010-10-06 08:39:16 EDT
*** Bug 605242 has been marked as a duplicate of this bug. ***
Comment 22 Milan Zázrivec 2010-10-19 11:47:58 EDT
Verified in stage (-> release_pending) with:

spacewalk-schema-1.2.21-8.el5sat.noarch
satellite-schema-5.4.0.8-1.el5sat.noarch
Comment 23 Clifford Perry 2010-10-28 10:51:13 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford
Comment 24 Michael Mráka 2011-01-28 10:04:03 EST
*** Bug 566029 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.