Bug 586117 - KMS needs more complete default mode list when no EDID present
Summary: KMS needs more complete default mode list when no EDID present
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
: 587804 (view as bug list)
Depends On:
Blocks: 586941 602914 846704
TreeView+ depends on / blocked
 
Reported: 2010-04-26 20:29 UTC by Phil Schaffner
Modified: 2017-12-06 10:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 10:52:37 UTC


Attachments (Terms of Use)
dmesg (19.87 KB, text/plain)
2010-04-29 14:38 UTC, Phil Schaffner
no flags Details
/var/log/messages (38.81 KB, text/plain)
2010-04-29 14:38 UTC, Phil Schaffner
no flags Details
/var/log/Xorg.0.log (36.00 KB, text/plain)
2010-04-29 14:39 UTC, Phil Schaffner
no flags Details
/var/log/Xorg.9.log (36.31 KB, text/plain)
2010-04-29 14:40 UTC, Phil Schaffner
no flags Details

Description Phil Schaffner 2010-04-26 20:29:12 UTC
Description of problem:
Since system-config-display is not included in RHEL6 Beta there seems to be no way to easily set a monitor choice if not automatically recognized.  For example, a test install in VirtualBox 3.1.6 is limited to 800x600 resolution.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt to set resolution higher than 800x600
2.Fail to find an option
3.
  
Actual results:
No way to select a monitor choice (e.g. Generic LCD 1600x1200) with higher resolution than 800x600 via the GUI interface.

Expected results:
An easy way to configure a monitor when not automatically recognized.

Additional info:
Either building system-config-display from Fedora 12 SRPM or copying an EL5 xorg.conf allows use of full monitor resolution.

Comment 2 RHEL Product and Program Management 2010-04-26 21:27:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Matěj Cepl 2010-04-28 05:48:07 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 4 Phil Schaffner 2010-04-29 14:38:03 UTC
Created attachment 410127 [details]
dmesg

The dmesg was run after a fresh Desktop install, firstboot, and GUI login.

Comment 5 Phil Schaffner 2010-04-29 14:38:56 UTC
Created attachment 410128 [details]
/var/log/messages

Comment 6 Phil Schaffner 2010-04-29 14:39:48 UTC
Created attachment 410130 [details]
/var/log/Xorg.0.log

Comment 7 Phil Schaffner 2010-04-29 14:40:42 UTC
Created attachment 410131 [details]
/var/log/Xorg.9.log

Comment 8 Phil Schaffner 2010-04-29 14:41:52 UTC
No /etc/X11/xorg.conf exists.

Comment 9 Bill Nottingham 2010-05-01 01:47:00 UTC
*** Bug 587804 has been marked as a duplicate of this bug. ***

Comment 10 Greg Nichols 2010-06-11 01:19:16 UTC
system-config-display is used by the video test of Red Hat's v7 hardware certification test suite to produce a configuration file for testing.   If this isn't included in RHEL6, we need a suggestion for replacing it.

Comment 11 RHEL Product and Program Management 2010-07-15 14:59:22 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 12 Adam Jackson 2010-08-24 19:04:48 UTC
(In reply to comment #10)
> system-config-display is used by the video test of Red Hat's v7 hardware
> certification test suite to produce a configuration file for testing.   If this
> isn't included in RHEL6, we need a suggestion for replacing it.

Replace it with nothing.  The X server should be able to come up with a reasonable configuration on its own now.

Comment 13 Phil Schaffner 2010-08-25 14:45:45 UTC
The operative word is "should".  In the cases where it does not, the user is left without a tool to gracefully manage the configuration.  I will happily work around it by rolling my own system-config-display from a Fedora SRPM, but this does not seem be the optimal solution for the distribution.

Comment 16 RHEL Product and Program Management 2011-01-07 04:35:29 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 17 Suzanne Yeghiayan 2011-01-07 16:07:18 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 18 RHEL Product and Program Management 2011-02-01 06:07:10 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 19 RHEL Product and Program Management 2011-02-01 18:18:03 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 22 Phil Schaffner 2011-06-14 13:06:07 UTC
There is still no system-config-display in 6.1.

Comment 23 RHEL Product and Program Management 2011-07-06 00:18:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 25 daryl herzmann 2011-08-16 21:43:23 UTC
Practical usage case...  Configuring the display for GDM so that an attached monitor/projector is mirrored and not xinerama/spanned by default.

Comment 26 daryl herzmann 2011-08-18 12:50:05 UTC
(In reply to comment #25)
> Practical usage case...  Configuring the display for GDM so that an attached
> monitor/projector is mirrored and not xinerama/spanned by default.

Hacky workaround...

1. Change gdm's login shell from /sbin/nologin to /bin/bash
2. Set some password for gdm
3. Log into GDM as user gdm (sick, hehe)
4. Run System Preferences -> Display tool to setup mirroring
5. Log out
6. Set gdm's login shell back to /sbin/nologin

Comment 28 Suzanne Yeghiayan 2012-01-31 21:14:40 UTC
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.

Comment 29 Adam Jackson 2012-04-20 18:07:52 UTC
system-config-display is not coming back, full stop.

What we _can_ do, when EDID fetch fails, is to make a more complete list of modes available and simply default to something conservative.  gnome-display-properties will then allow you to set the desired resolution at runtime.  (Pushing that preference into gdm's configuration is a gnome problem.)

Fixing this in the general case requires fixing both the kernel (for the KMS drivers) and the individual drivers (for everything else).  Reassigning this bug to the kernel since KMS is the preferred support path.  Please clone this bug for any non-KMS-enabled drivers that also need this enhancement.

Comment 30 RHEL Product and Program Management 2012-07-10 06:06:53 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 31 RHEL Product and Program Management 2012-07-10 23:33:18 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 32 RHEL Product and Program Management 2013-10-14 05:24:41 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 33 Jan Kurik 2017-12-06 10:52:37 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.