Bug 586941 - v7 on RHEL6 requires rpms not in RHEL6: system-config-display
v7 on RHEL6 requires rpms not in RHEL6: system-config-display
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.1
All Linux
high Severity high
: ---
: ---
Assigned To: Greg Nichols
CAI Qian
:
: 584501 605583 609453 612316 (view as bug list)
Depends On: 586117
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 10:41 EDT by Greg Nichols
Modified: 2010-10-23 11:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The system-config-display utility is no longer required.
Story Points: ---
Clone Of:
: 602914 (view as bug list)
Environment:
Last Closed: 2010-09-20 08:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
video test patch for testing without X config files on RHEL6 (8.51 KB, patch)
2010-08-03 13:41 EDT, Greg Nichols
gnichols: review? (rlandry)
Details | Diff

  None (edit)
Description Greg Nichols 2010-04-28 10:41:02 EDT
Description of problem:

v7 requires rpms not found in RHEL6:

Rechecking required rpms
The following rpms are required for testing:
 qemu-kvm-tools system-config-display



Version-Release number of selected component (if applicable):

v7 1.1 R23
RHEL 6 beta 1
Comment 1 Gary Case 2010-06-10 17:15:41 EDT
This persists in v7 1.2-3. The tool still asks for system-config-display to be installed, but it doesn't exist. 

By the way, why are these dependencies not called out in the RPM itself? I install using a yum repo for the v7 package, but I'm still left with missing dependencies when I complete the install. This is the exact reason people use @everything installs when they try to cert RHEL.

[root@dhcp8 ~]# v7 plan
Tested OS: Red Hat Enterprise Linux Server 6 (Santiago)
Kernel RPM: kernel-2.6.32-30.el6
v7 version 1.2, release 3
Hardware: Sun Microsystems unknown Volans
OS: Santiago 6
saved configuration to /var/v7/results.xml
Created a new plan with 15 tests on 139 devices
Checking for additional required packages based on the test plan:
cdrom requires dvd+rw-tools, genisoimage, wodim
dvd requires dvd+rw-tools, genisoimage, wodim
audio requires sox
fv_network requires libvirt, libvirt-python, python-virtinst, qemu-kvm-tools, python-virtinst
fv_memory requires libvirt, libvirt-python, python-virtinst, qemu-kvm-tools, python-virtinst
profiler requires oprofile
video requires xorg-x11-apps, system-config-display
fv_core requires libvirt, libvirt-python, python-virtinst, qemu-kvm-tools, python-virtinst
fv_storage requires libvirt, libvirt-python, python-virtinst, qemu-kvm-tools, python-virtinst
info requires kernel-devel
The following rpms are required for testing:
 qemu-kvm-tools xorg-x11-apps dvd+rw-tools wodim genisoimage system-config-display sox
Would you like to install them now? (y|n) y
response: y
Running yum: --------------------------------
This system is not registered with RHN.
RHN support will be disabled.
Error: Could not install rpm
"yum install -y  qemu-kvm-tools xorg-x11-apps dvd+rw-tools wodim genisoimage system-config-display sox" has output on stderr
Rechecking required rpms
The following rpms are required for testing:
 system-config-display
Would you like to install them now? (y|n)
Comment 2 Gary Case 2010-06-10 17:18:59 EDT
Still in 1.2-5, too.
Comment 3 Greg Nichols 2010-06-10 20:50:34 EDT
system-config-display is only required for the video test, which may not apply to some systems.   Similarly, virtualization testing is not applicable to all systems.   So v7 now defers some rpm installation to follow test planning, so as not to require (via rpm spec) rpms on systems where they're not applicable.

Note that you can answer "n" to the second prompt, and continue testing.  I suspect the video test may fail.  Is there some other impact of this bug 
that I'm missing?
Comment 4 Greg Nichols 2010-06-10 21:24:35 EDT
split off qemu-kvm-tools to bz #602914
Comment 5 Greg Nichols 2010-06-18 10:06:53 EDT
*** Bug 605583 has been marked as a duplicate of this bug. ***
Comment 6 Greg Nichols 2010-07-06 13:05:10 EDT
*** Bug 609453 has been marked as a duplicate of this bug. ***
Comment 7 Greg Nichols 2010-07-07 16:52:23 EDT
*** Bug 612278 has been marked as a duplicate of this bug. ***
Comment 8 Greg Nichols 2010-07-07 16:53:49 EDT
*** Bug 612316 has been marked as a duplicate of this bug. ***
Comment 9 Greg Nichols 2010-08-03 13:41:03 EDT
Created attachment 436338 [details]
video test patch for testing without X config files on RHEL6


This patch changes the video test for RHEL6 to work without the generation of a config file.    This means that system-config-display will not be needed.   The test adds some plan-time-required rpms to insure that X and startx are installed.
Comment 11 Greg Nichols 2010-08-09 12:52:38 EDT
*** Bug 584501 has been marked as a duplicate of this bug. ***
Comment 13 qcui 2010-08-25 02:39:35 EDT
Verified it with R20.el6.
Comment 16 errata-xmlrpc 2010-09-20 08:13:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html
Comment 17 Jaromir Hradilek 2010-09-21 08:49:58 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The system-config-display utility is no longer required.

Note You need to log in before you can comment on or make changes to this bug.