Bug 586121 - problems in the devel subpackage
Summary: problems in the devel subpackage
Status: CLOSED DUPLICATE of bug 599495
Alias: None
Product: Fedora
Classification: Fedora
Component: bullet   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Thomas Kowaliczek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-26 20:35 UTC by Dan Horák
Modified: 2010-08-20 23:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 23:27:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Horák 2010-04-26 20:35:10 UTC
I see two problems in the devel subpackage
- headers are installed directly in /usr/include, but bullet.pc exports /usr/include/bullet (which should be preferred)
- library names in the bullet.pc file are all in lowercase, but in fact they are MixedCase

I will try to prepare a patch for the bullet pkgconfig and spec files.

Comment 1 Thomas Kowaliczek 2010-04-26 21:13:23 UTC
that would be nice if you can give me an patch.
But the problem is here the cmake build system don´t do that correct and i don´t have the time to fix that in upstream.

Comment 2 Dan Horák 2010-04-27 07:40:26 UTC
Thomas, do you know what buildsystem (cmake, autotools, ...) is supported/preferred by upstream? The bullet.pc problems are caused by using cmake instead of autotools to build bullet. They both produce libraries with different filenames ...

Comment 3 Thomas Kowaliczek 2010-04-27 09:03:48 UTC
Autotools are supported by upstream. I would change it to autotools but i don´t know how to remove the extra packages that are not needed.

Comment 4 Thomas Kowaliczek 2010-08-20 23:27:33 UTC

*** This bug has been marked as a duplicate of bug 599495 ***


Note You need to log in before you can comment on or make changes to this bug.