Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 599495 - bullet.pc contains wrong entries
bullet.pc contains wrong entries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bullet (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Thomas Kowaliczek
Fedora Extras Quality Assurance
:
: 586121 619885 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 07:19 EDT by Julian Leyh
Modified: 2010-08-31 02:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: bullet-2.75-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-31 02:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Leyh 2010-06-03 07:19:20 EDT
Description of problem:
pkg-config file bullet.pc names other libraries than actually installed.

Version-Release number of selected component (if applicable):
bullet-2.75-2.fc12.x86_64
bullet-devel-2.75-2.fc12.x86_64

How reproducible:
pkg-config bullet --libs
  
Actual results:
-lbulletdynamics -lbulletcollision -lbulletmath

Expected results:
-lBulletDynamics -lBulletCollision -lBulletSoftBody  

Additional info:
cflags are wrong, too
Comment 1 Thomas Kowaliczek 2010-08-20 19:26:12 EDT
*** Bug 619885 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Kowaliczek 2010-08-20 19:27:34 EDT
*** Bug 586121 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-08-20 19:29:57 EDT
bullet-2.75-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bullet-2.75-4.fc13
Comment 4 Fedora Update System 2010-08-21 00:34:13 EDT
bullet-2.75-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bullet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bullet-2.75-4.fc13
Comment 5 Fedora Update System 2010-08-31 02:34:41 EDT
bullet-2.75-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.