Bug 586201 - Broken keyboard mapping
Broken keyboard mapping
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 606514 614606 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 00:09 EDT by Mattias Ellert
Modified: 2010-07-30 04:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-manager-0.8.4-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 04:33:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2010-04-27 00:09:10 EDT
Description of problem:
When I type things in the virtual machine the keyboard mapping is screwed up. 

Version-Release number of selected component (if applicable):
virt-manager-0.8.3-3.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start the virt-manager on a non-en_US Fedora 13 system
2. Create a new virtual machine from an installation iso image
3. When asked to type things during the installation the keyboard mapping is broken.
  
Actual results:
Keys that are common between the en_US and the system's keyboard layout works fine. However, if I try to use a key where the mapping differs it is screwed up.

Expected results:
Working keyboard mapping

Additional info:
This works fine on Fedora 12.
Comment 1 Cole Robinson 2010-05-10 11:58:19 EDT
Thanks for the report, we need to backport this change:

http://hg.fedorahosted.org/hg/virt-manager/rev/99cf13a133f3
Comment 2 Fedora Update System 2010-05-27 17:00:17 EDT
virt-manager-0.8.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.4-1.fc13
Comment 3 Fedora Update System 2010-05-28 14:09:35 EDT
virt-manager-0.8.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.4-1.fc13
Comment 4 William Lovaton 2010-05-29 16:39:08 EDT
Mmmm... I'm seeing the same problem here but I saw this on Fedora 12 and still see it in Fedora 13.  I never got to report this bug back then because the workaround was very simple:

In /etc/libvirt/qemu/virtualMachine.xml find the <graphics> tag and remove the attribute "keymap".  It always defaults to "en-us" causing the problems mentioned in this bug report.

I guess the the real fix would be for the admin tool not to put this parameter in the xml config file or put the same keymap as the host keyboard.  But again, there is no way to know for sure what is the keymap configured inside the VM.
Comment 5 Cole Robinson 2010-06-01 09:53:48 EDT
William, your suggested change is exactly what the updated virt-manager does. However, for existing guests, this update won't fix the keymapping issue. 

To fix keymappings for existing guests:

- Install virt-manager-0.8.4-1.fc13 from updates testing
- Run virt-manager, go to Hardware Details section for the existing VM. The VM must be turned off.
- Remove the 'display' device
- Click 'Add Hardware' in the bottom left corner
- Select 'Graphics', click 'forward'
- click 'forward' again, creating a VNC graphics device with the default settings.
- click 'finish'

Keymapping should now be set up correctly
Comment 6 Cole Robinson 2010-06-02 12:21:01 EDT
ellert, I saw your update comment saying this is still an issue for new guests. Do the workaround steps above fix the issue for existing guests? 

Can you provide the output of virt-manager --debug when creating a new guest? And virt-manager --version just to be certain.
Comment 7 Mattias Ellert 2010-06-10 13:59:57 EDT
(In reply to comment #6)
> ellert, I saw your update comment saying this is still an issue for new guests.
> Do the workaround steps above fix the issue for existing guests? 
> 
> Can you provide the output of virt-manager --debug when creating a new guest?
> And virt-manager --version just to be certain.    

I did my Fedora 13 installation at a time when bug #571900 had not yet been fixed, so my /etc/sysconfig/keyboard file said I had a US keyboard layout, even though I chose Swedish during installation.

I had not noticed this, since nothing else I had done with the computer uses the information in this file to set the keyboard layout - except for the keyboard layout used before choosing which user to log in as on the login screen. But I always click on my name and then the keyboard layout changes to my preferred layout for me to type the password - so I never noticed this.

Anyway I edited the /etc/sysconfig/keyboard file to say that I have a Swedish keyboard, and then the keyboard layout in the guest works.

However, if I now choose to start my gdm session with a US keyboard layout and then try to start a new guest I get the same trouble again, since now /etc/sysconfig/keyboard and the gdm session disagrees again.

I think that the trouble is that you treat the /etc/sysconfig/keyboard as an authoritative source for the hosts keyboard mapping, instead of querying the gdm session.
Comment 8 Cole Robinson 2010-07-14 17:15:48 EDT
*** Bug 614606 has been marked as a duplicate of this bug. ***
Comment 9 Cole Robinson 2010-07-14 17:16:21 EDT
*** Bug 606514 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2010-07-15 13:20:06 EDT
virt-manager-0.8.4-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.4-2.fc13
Comment 11 Fedora Update System 2010-07-15 17:02:02 EDT
virt-manager-0.8.4-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.4-2.fc13
Comment 12 William Lovaton 2010-07-20 19:23:09 EDT
This update seems to be working fine so far.  It would be great to push this package to the official updates repo.
Comment 13 Fedora Update System 2010-07-30 04:33:11 EDT
virt-manager-0.8.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.