Bug 614606 - AltGr key does not work when using virt-manager
Summary: AltGr key does not work when using virt-manager
Status: CLOSED DUPLICATE of bug 586201
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
urgent
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-14 20:50 UTC by Lebenskuenstler
Modified: 2010-07-14 21:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 21:15:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lebenskuenstler 2010-07-14 20:50:09 UTC
Description of problem:

I did install a Windows 7 using virt-manager and qemu-kvm as hypervisor. I need to use the US international layout. In Win7 using virt-manager this does not work.

I started the Windows 7 image by using qemu-kvm from the command line in order to avoid the use of virt-manager, there AltGr key works.

I already tried  libvirt.x86_64 0:0.8.2-1.fc13 from updates-testing.

Comment 1 Cole Robinson 2010-07-14 20:55:29 UTC
Please provide sudo virsh dumpxml $vmname

Comment 2 Lebenskuenstler 2010-07-14 21:04:02 UTC
Here it is:

[root@calvin images]# virsh dumpxml Windoof7
<domain type='kvm' id='1'>
  <name>Windoof7</name>
  <uuid>35ff7209-c14e-681d-a658-fcd48f27a532</uuid>
  <memory>2097152</memory>
  <currentMemory>2097152</currentMemory>
  <vcpu>2</vcpu>
  <os>
    <type arch='x86_64' machine='fedora-13'>hvm</type>
    <boot dev='hd'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <cpu match='exact'>
    <model>qemu64</model>
    <feature policy='force' name='x2apic'/>
  </cpu>
  <clock offset='localtime'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>restart</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw'/>
      <source file='/var/lib/libvirt/images/Windoof7.img'/>
      <target dev='hda' bus='ide'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    </disk>
    <disk type='block' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source dev='/dev/sr0'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <alias name='ide0-1-0'/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>
    <interface type='network'>
      <mac address='52:54:00:17:a3:6e'/>
      <source network='default'/>
      <target dev='vnet0'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </interface>
    <serial type='pty'>
      <source path='/dev/pts/0'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
    <console type='pty' tty='/dev/pts/0'>
      <source path='/dev/pts/0'/>
      <target port='0'/>
      <alias name='serial0'/>
    </console>
    <input type='tablet' bus='usb'>
      <alias name='input0'/>
    </input>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='5900' autoport='yes' keymap='en-us'/>
    <sound model='ac97'>
      <alias name='sound0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    </sound>
    <video>
      <model type='vga' vram='9216' heads='1'/>
      <alias name='video0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    </video>
  </devices>
  <seclabel type='dynamic' model='selinux'>
    <label>system_u:system_r:svirt_t:s0:c109,c731</label>
    <imagelabel>system_u:object_r:svirt_image_t:s0:c109,c731</imagelabel>
  </seclabel>
</domain>

Comment 3 Cole Robinson 2010-07-14 21:10:35 UTC
if you 'virsh edit $vmname' and remove the keymap= piece from <graphics>, restart the guest, do things get better?

Comment 4 Cole Robinson 2010-07-14 21:15:48 UTC
Pretty sure this is just 586201

*** This bug has been marked as a duplicate of bug 586201 ***

Comment 5 Lebenskuenstler 2010-07-14 21:25:11 UTC
Yes. Thank you.


Note You need to log in before you can comment on or make changes to this bug.