Bug 586283 - smc-dyuthi-fonts isn't usable
smc-dyuthi-fonts isn't usable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smc-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Naveen Kumar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 586890
  Show dependency treegraph
 
Reported: 2010-04-27 04:48 EDT by Akira TAGOH
Modified: 2010-07-30 04:36 EDT (History)
9 users (show)

See Also:
Fixed In Version: smc-fonts-4.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586890 (view as bug list)
Environment:
Last Closed: 2010-07-29 01:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TTF of Dyuthi Version 1.0.1 (203.31 KB, application/x-font-ttf)
2010-04-30 14:53 EDT, Hiran Venugopalan
no flags Details

  None (edit)
Description Akira TAGOH 2010-04-27 04:48:39 EDT
Description of problem:
smc-dyuthi-fonts is supposed to work for Malayalam font though, it doesn't have enough glyph coverage in fontconfig.

Version-Release number of selected component (if applicable):
smc-dyuthi-fonts-04.2-7.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1.fc-match -v "Dyuthi"|grep -E "        lang"|grep ml
2.
3.
  
Actual results:
No output

Expected results:
the lang spec should contains or.

Additional info:
Comment 1 Akira TAGOH 2010-04-27 04:49:08 EDT
This is raised during the testing of Bug#578046.
Comment 2 Akira TAGOH 2010-04-27 04:51:45 EDT
Doh. I meant:

Expected results:
the lang spec should contains _ml_.
Comment 3 Naveen Kumar 2010-04-29 08:47:28 EDT
The Unicode value of U+0D0C specified in ml.orth is missing in this font and
hence script/language requirement is not fulfilled.

Adding a glyph for U+0D0C would solve this problem.
Comment 4 Hiran Venugopalan 2010-04-30 14:53:08 EDT
Created attachment 410570 [details]
TTF of Dyuthi Version 1.0.1

Dyuthi with U+ODOC.
Comment 5 Naveen Kumar 2010-05-03 03:06:28 EDT
(In reply to comment #4)
> Created an attachment (id=410570) [details]
> TTF of Dyuthi Version 1.0.1
> 
> Dyuthi with U+ODOC.    

Thanks Hiran :) Just wanted to ask will this be fixed in upstream too...
Comment 6 Pravin Satpute 2010-05-03 04:18:55 EDT
(In reply to comment #4)
> Created an attachment (id=410570) [details]
> TTF of Dyuthi Version 1.0.1
> 
> Dyuthi with U+ODOC.    

Still gnome font viewer showing font version 1.0

can you update version in 
1) Elements-> Font Information -> Names and in
2) Elements-> Font Information -> TTF names as well?


It will be nice if you release .sfd as well

Thanks for fix
Comment 7 Akira TAGOH 2010-07-13 04:28:29 EDT
Any plans to push the updates and get this fixed in?
Comment 8 Naveen Kumar 2010-07-13 04:50:16 EDT
Upstream has informed me that they are doing some enhancement work. Therefore, I have to wait till they finish. But probably, I would be able to finish it by this weekend.
Comment 9 Rajeesh 2010-07-13 10:07:27 EDT
just talked to Hiran and the version is bumped in git : git://git.savannah.gnu.org/smc/fonts.git
Comment 10 Praveen Arimbrathodiyil 2010-07-14 04:15:42 EDT
Rajeesh,

Did you forget to push your commits? I don't see any of your changes in git 
http://git.savannah.gnu.org/gitweb/?p=smc/fonts.git
Comment 11 Rajeesh 2010-07-14 09:16:36 EDT
The version was already bumped to 1.0.1 yesterday when I checked with Hiran. see http://git.savannah.gnu.org/cgit/smc/fonts.git/tree/Dyuthi/Dyuthi.sfd
Comment 12 Naveen Kumar 2010-07-15 02:56:44 EDT
Thanks guys! I will try and push it today itself.
Comment 13 Fedora Update System 2010-07-16 05:23:04 EDT
smc-fonts-4.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/smc-fonts-4.4-1.fc13
Comment 14 Fedora Update System 2010-07-16 14:49:31 EDT
smc-fonts-4.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smc-fonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/smc-fonts-4.4-1.fc13
Comment 15 Pravin Satpute 2010-07-26 07:07:53 EDT
(In reply to comment #0)

> Steps to Reproduce:
> 1.fc-match -v "Dyuthi"|grep -E "        lang"|grep ml

looks like some problem happens while pasting 

it should be

$fc-match -v "Dyuthi"|grep -E "lang"|grep ml
Comment 16 Naveen Kumar 2010-07-29 01:54:45 EDT
Closing the bug, if problem persists, please reopen it again.
Comment 17 Fedora Update System 2010-07-30 04:36:43 EDT
smc-fonts-4.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.