Bug 586293 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Keywords:
Status: CLOSED DUPLICATE of bug 556926
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:84023794db18a36cfacf215a4c0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 09:07 UTC by Ronald Canete
Modified: 2010-04-27 14:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-27 14:46:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (97.04 KB, text/plain)
2010-04-27 09:07 UTC, Ronald Canete
no flags Details

Description Ronald Canete 2010-04-27 09:07:43 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox http://art.gnome.org/backgrounds/
component: firefox
executable: /usr/lib/firefox-3.5/firefox
global_uuid: 84023794db18a36cfacf215a4c0f63b59c452bea
kernel: 2.6.32.11-99.fc12.i686.PAE
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 Ronald Canete 2010-04-27 09:07:55 UTC
Created attachment 409402 [details]
File: backtrace

Comment 2 Chris Campbell 2010-04-27 14:38:40 UTC
#7  0x0053ebd8 in __assert_fail (assertion=0x79cddb "ret != inval_id", 
    file=0x79cda9 "xcb_io.c", line=378, function=0x79cf5c "_XAllocID")
    at assert.c:81
        buf = 0x9ae26790 "firefox: xcb_io.c:378: _XAllocID: Assertion `ret != inval_id' failed.\n"
#8  0x0072cc0a in _XAllocID (dpy=0xb7661000) at xcb_io.c:378
        ret = 4294967295
        __PRETTY_FUNCTION__ = "_XAllocID"
#9  0x00bfac48 in XRenderCreatePicture (dpy=<value optimized out>, 
    drawable=<value optimized out>, format=<value optimized out>, 
    valuemask=<value optimized out>, attributes=<value optimized out>)
    at Picture.c:90
        info = 0xb768b130
        pid = <value optimized out>
#10 0x001fdf7a in _cairo_xlib_surface_ensure_dst_picture (surface=0x9d078180)
    at cairo-xlib-surface.c:887
No locals.
#11 0x001ff897 in _cairo_xlib_surface_composite_trapezoids (
    op=CAIRO_OPERATOR_OVER, pattern=0x9d0211f0, abstract_dst=0x9d078180, 
    antialias=CAIRO_ANTIALIAS_DEFAULT, src_x=466, src_y=78, dst_x=466, 
    dst_y=78, width=10, height=6, traps=0x9ff26000, num_traps=9)
    at cairo-xlib-surface.c:2149
        attributes = {matrix = {xx = 1, yx = 0, xy = 0, yy = 1, x0 = 0, 
            y0 = 0}, extend = CAIRO_EXTEND_REPEAT, 
          filter = CAIRO_FILTER_NEAREST, x_offset = 0, y_offset = 0, 
          acquired = 0, extra = 0xbf9402e4}
        src = 0x9d0787c0
        status = CAIRO_INT_STATUS_UNSUPPORTED
        operation = <value optimized out>
        render_reference_x = 467
        render_reference_y = 78
        pict_format = 0xb7610060
#12 0x001e4103 in _cairo_surface_composite_trapezoids (
    op=CAIRO_OPERATOR_OVER, pattern=0x9d0211f0, dst=0x9d078180, 
    antialias=CAIRO_ANTIALIAS_DEFAULT, src_x=466, src_y=78, dst_x=466, 
    dst_y=78, width=10, height=6, traps=0x9ff26000, num_traps=9)
    at cairo-surface.c:1724
        status = <value optimized out>
        __PRETTY_FUNCTION__ = "_cairo_surface_composite_trapezoids"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-04-27 14:46:35 UTC
Thank you for taking the time to make this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 556926 ***


Note You need to log in before you can comment on or make changes to this bug.