Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 586344 - /usr/sbin/rhn-profile-sync failes when running stuff from python-dmidecode
Summary: /usr/sbin/rhn-profile-sync failes when running stuff from python-dmidecode
Keywords:
Status: CLOSED DUPLICATE of bug 583867
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-dmidecode
Version: 5.5
Hardware: i686
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: David Sommerseth
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 11:20 UTC by Morten Werner Forsbring
Modified: 2016-05-22 23:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-21 13:44:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Content from /usr/share/rhn/up2date_client/hardware.py to reproduce the error (3.84 KB, application/octet-stream)
2010-04-27 11:20 UTC, Morten Werner Forsbring
no flags Details

Description Morten Werner Forsbring 2010-04-27 11:20:39 UTC
Created attachment 409441 [details]
Content from /usr/share/rhn/up2date_client/hardware.py to reproduce the error

Description of problem:
When /usr/sbin/rhn-profile-sync runs, we get this error from python-dmidecode:
python: src/dmidecode.c:4083: dmi_decode: Assertion `sub_n != ((void *)0)' failed.
Aborted

Version-Release number of selected component (if applicable):
dmidecode-2.10-3.el5
python-dmidecode-3.10.8-4.el5

How reproducible:
Every time on two different hardware models (three boxes):

 * HP Compaq dc7100 SFF(DX878AV)
 * HP Compaq dc7100 SFF(PE218ET)

Steps to Reproduce:
I'll add a small python-script which can be used to reproduce the error on
the three boxes we experience problems.
  
Actual results:
nemi /# /tmp/pydmitest 
python: src/dmidecode.c:4083: dmi_decode: Assertion `sub_n != ((void *)0)' failed.
Aborted
nemi /#

Expected results:
mariner /# /tmp/pydmitest 
mariner /#

Comment 1 David Sommerseth 2010-05-21 13:44:01 UTC
Thank you for reporting this issue.  This particular issue seems to have been reported in bug #583867.  Thus marking this bug as a duplicate, as I believe the solution will be closed with that fix.

*** This bug has been marked as a duplicate of bug 583867 ***


Note You need to log in before you can comment on or make changes to this bug.