Bug 583867 - Assertion when decoding DMI type 0x08 on pogolinux-1.rhts.eng.rdu.redhat.com
Assertion when decoding DMI type 0x08 on pogolinux-1.rhts.eng.rdu.redhat.com
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-dmidecode (Show other bugs)
5.5
All Linux
urgent Severity high
: rc
: ---
Assigned To: Roman Rakus
qe-baseos-daemons
: ZStream
: 586344 619732 630095 (view as bug list)
Depends On:
Blocks: 596133 596264 621146 1058872
  Show dependency treegraph
 
Reported: 2010-04-20 00:19 EDT by Jan Hutař
Modified: 2014-01-28 11:49 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 596264 (view as bug list)
Environment:
Last Closed: 2013-09-23 07:01:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode output on that system (19.26 KB, text/plain)
2010-04-20 00:21 EDT, Jan Hutař
no flags Details
Patch fixing the assert() issue (3.02 KB, patch)
2010-04-20 07:16 EDT, David Sommerseth
no flags Details | Diff

  None (edit)
Description Jan Hutař 2010-04-20 00:19:03 EDT
Description of problem:
I can not register to RHN pogolinux-1.rhts.eng.rdu.redhat.com.


Version-Release number of selected component (if applicable):
Tested with both versions:
rhn-client-tools-0.4.20-33.el5
rhn-client-tools-0.4.20-33.el5_5.1


How reproducible:
2 of 2 attempts


Steps to Reproduce:
1. rhnreg_ks --activationkey=518f549706ddc643ef969686dee6de1f --force
2. rhn_register


Actual results:
# grep serverURL= /etc/sysconfig/rhn/up2date
serverURL=https://xmlrpc.rhn.errata.stage.redhat.com/XMLRPC
# rhnreg_ks --activationkey=518f549706ddc643ef969686dee6de1f --force
python: src/dmidecode.c:4083: dmi_decode: Assertion `sub_n != ((void *)0)' failed.
Aborted
# echo $?
134

rhn_register shows me this error as well


Expected results:
Should work as expected.
Comment 2 Jan Hutař 2010-04-20 00:21:50 EDT
Created attachment 407721 [details]
dmidecode output on that system

dmidecode-2.10-3.el5
python-dmidecode-3.10.8-4.el5
Comment 3 Milan Zazrivec 2010-04-20 04:27:36 EDT
David, any idea what might be causing this error?

Thanks.
Comment 4 David Sommerseth 2010-04-20 07:16:07 EDT
Created attachment 407791 [details]
Patch fixing the assert() issue

I've found the error and have gotten the fix pushed upstream.  I've moved this bug over to python-dmidecode, as this is where the error was.

I'll prepare a new python-dmidecode package for RHEL5.5 and RHEL6 when a new release comes - which should be rather soon.

Attached a patch with the fix itself.
Comment 5 Fedora Update System 2010-04-30 05:20:56 EDT
python-dmidecode-3.10.12-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-dmidecode-3.10.12-1.fc12
Comment 6 Fedora Update System 2010-04-30 05:21:21 EDT
python-dmidecode-3.10.12-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/python-dmidecode-3.10.12-1.fc13
Comment 7 Fedora Update System 2010-04-30 05:22:46 EDT
python-dmidecode-3.10.12-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/python-dmidecode-3.10.12-1.el4
Comment 8 Fedora Update System 2010-04-30 05:32:41 EDT
python-dmidecode-3.10.12-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-dmidecode-3.10.12-1.fc11
Comment 11 Fedora Update System 2010-05-10 19:51:55 EDT
python-dmidecode-3.10.12-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-05-11 15:38:37 EDT
python-dmidecode-3.10.12-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-05-18 17:49:48 EDT
python-dmidecode-3.10.12-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 David Sommerseth 2010-05-21 09:44:01 EDT
*** Bug 586344 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2010-05-25 20:02:37 EDT
python-dmidecode-3.10.12-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 David Sommerseth 2010-06-04 04:05:55 EDT
Upstream patch for the SEGV fault is accepted and python-dmidecode-3.10.13 was released yesterday.  Awaiting packaging of new version.  That package will fix both this issue and the SEGV issue.
Comment 26 Milan Zazrivec 2010-07-30 07:22:44 EDT
*** Bug 619732 has been marked as a duplicate of this bug. ***
Comment 29 Pavel Novotny 2010-09-07 08:57:30 EDT
*** Bug 630095 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.