Bug 586406 - vnc session keyboard up-arrow mapped incorrectly
vnc session keyboard up-arrow mapped incorrectly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 580159 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 09:46 EDT by Eric Frey
Modified: 2013-04-30 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: tigervnc-1.0.90-0.11.20100420svn4030.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-18 17:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Frey 2010-04-27 09:46:06 EDT
Description of problem:

Using today's test updates.  On a vnc session, (using RealVNC client). hitting the up arrow key echoes as "A" on a gnome-terminal session.

Using xev, we can see what vnc is seeing, and we see an "extra" keypress of Shift_L:

KeyPress event, serial 33, synthetic NO, window 0x1000001,
    root 0xfc, subw 0x0, time 56145754, (301,312), root:(384,388),
    state 0x0, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x1000001,
    root 0xfc, subw 0x0, time 56145754, (301,312), root:(384,388),
    state 0x1, keycode 98 (keysym 0xff52, Up), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x1000001,
    root 0xfc, subw 0x0, time 56145754, (301,312), root:(384,388),
    state 0x1, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 33, synthetic NO, window 0x1000001,
    root 0xfc, subw 0x0, time 56145839, (301,312), root:(384,388),
    state 0x0, keycode 98 (keysym 0xff52, Up), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False


The exact same client has no issues VNCing to F11, CentOS of various flavors, Win 7.


Version-Release number of selected component (if applicable):

  tigervnc.x86_64 0:1.0.90-0.10.20100420svn4030.fc13                            
  tigervnc-server.x86_64 0:1.0.90-0.10.20100420svn4030.fc13                     
  tigervnc-server-module.x86_64 0:1.0.90-0.10.20100420svn4030.fc13              
 

How reproducible:

100%

Steps to Reproduce:
1. vncserver -geometry 2000x1400 -depth 24 :40
2. connect to the VNC session from another machine
3. start a gnome-terminal, hit the up arrow key.  Then, start xev on the terminal, after the initial event flow stops, hit up arrow again.  You should see the key events recorded above.

Same problem will occur with xterm; also, the problem isn't dependent on an of the vncserver settings.

  
Actual results:


Expected results:


Additional info:
Comment 1 Eric Frey 2010-04-28 11:25:25 EDT
This is completely blocking my ability to use F13; priority and severity should be raised.
Comment 2 Eric Frey 2010-04-29 08:42:39 EDT
This is completely blocking my ability to use F13; priority and severity should be raised.
Comment 3 Adam Tkac 2010-05-10 07:35:09 EDT
Patch for this issue is ready but I would like to release it together with fix for bug #580159, which is not ready yet. You can download fixed version from http://koji.fedoraproject.org/koji/taskinfo?taskID=2176906.
Comment 4 Eric Frey 2010-05-10 08:15:37 EDT
Bug fixed.  Thank you.
Comment 5 Adam Tkac 2010-05-13 06:49:19 EDT
*** Bug 580159 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2010-05-13 06:49:47 EDT
tigervnc-1.0.90-0.11.20100420svn4030.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.11.20100420svn4030.fc13
Comment 7 Paul W. Frields 2010-05-13 11:25:34 EDT
The update in comment #6 takes care of the bug for me.  I gave appropriate karma in the update listing, recommend other reporters test and do the same.
Comment 8 Fedora Update System 2010-05-13 15:27:34 EDT
tigervnc-1.0.90-0.11.20100420svn4030.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/tigervnc-1.0.90-0.11.20100420svn4030.fc13
Comment 9 Fedora Update System 2010-05-18 17:52:23 EDT
tigervnc-1.0.90-0.11.20100420svn4030.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Avi Tal 2010-09-15 10:38:25 EDT
i have tigervnc-1.0.90-0.13.20100420svn4030.fc13.x86_64
and still the keyboard up-arrow mapped incorrectly!

Note You need to log in before you can comment on or make changes to this bug.