Bug 586461 - [RFE] Support for NFSv4 missing.
[RFE] Support for NFSv4 missing.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
: FutureFeature, Triaged
Depends On: 618759
Blocks: 554476 595547
  Show dependency treegraph
 
Reported: 2010-04-27 12:36 EDT by Zak Brown
Modified: 2016-04-26 10:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 595547 618759 (view as bug list)
Environment:
Last Closed: 2010-09-22 13:04:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zak Brown 2010-04-27 12:36:57 EDT
Description of problem:

The NFS service within cluster suite does not allow for the NFS version to be specified.  Thus the service defaults to the RHEL default of v3.

If NFSv4 is required the script resource or another customer solution must be employed.

It also stands to reason that in certain circumstances you might wish to change some of the other defaults like rsize and wsize.

So perhaps it would make sense to change the NFS agent so that any nfs configuration option could be implemented.
Comment 1 Micheal Waltz 2010-04-28 14:07:47 EDT
Opened case in RHN: 2016970
Comment 2 Lon Hohberger 2010-04-29 14:16:00 EDT
Need some input here:

- this is supposed to be RHEL5 right?

- How many NFS servers are going to be managed in the desired use case(s)?

- What security features, if any, are required?
Comment 3 Lon Hohberger 2010-04-29 15:27:43 EDT
- This is for using the cluster as an NFS server, correct (as opposed to using NFS as a data store, thereby being a client)?
Comment 5 Zak Brown 2010-04-29 17:13:34 EDT
Yes RHEL 5.

This is for the NFSv4 server.

The desired use case is for two servers.  Active/Passive though the ability to have additional passive backups would be helpful.

The security features requested are simply the normal nfs access control.

However it would be helpful to be able to specify any of the options that are normally available in /etc/exports.

I'll ask the customer to add further color to this.

-Zak
Comment 6 Lon Hohberger 2010-05-05 09:57:07 EDT
Clarification -- what I meant was...

Do they need:

a) 1 nfs service per cluster (any number of backups for failover), or

b) 2+ nfs services per cluster where the services can coexist on the same cluster node.

The former is not terribly difficult, I think.  The latter is quite difficult and would require substantial work to get right (if it's possible at all).
Comment 7 Micheal Waltz 2010-05-05 14:22:37 EDT
Currently we just need option A for a single NFS service that supports multiple exports.

We would like option B in the future but it's not a priority.
Comment 8 Lon Hohberger 2010-07-27 10:18:38 EDT
In RHEL6 there is a kernel enhancement which makes this feasible - it sets up the pseudoroot namespace when the first export is fed in.  This in turn allows 'exportfs' to work largely as it does today.

Actually, we added NFSv4 support to RHEL6:

http://git.fedorahosted.org/git/?p=cluster.git;a=blob;f=rgmanager/src/resources/nfsserver.sh;h=17f472d0d21d6b53dd27afe4bce690f25d9c05d8;hb=348d5e9b4b3cd92e8739a5fc3b9e6bd2809dc722

On RHEL5, setting up the NFSv4 server requires setting up a pseudo-root file system explicitly, which is not particularly easy to do in a sane way in a cluster with more than one export.

More to the point, any work done on RHEL5 will not work on RHEL6 and vice-versa due to differences in the way NFSv4 setup is performed in those releases.  There is also no sane way to do configuration upgrade compatibility - users of a resource-agent designed for RHEL5 would have no migration path; it would be a dead-end feature.

So, we'd need the kernel enhancement from RHEL6 backported to RHEL5 before this is feasible.
Comment 9 Lon Hohberger 2010-07-27 12:44:46 EDT
I scoped this out with one of the developers who implemented the kernel feature.  The following packages will require changes in order for the cluster to provide a native nfsv4 agent on Red Hat Enterprise Linux 5:

 - kernel
 - nfs-utils
 - rgmanager

Additionally, for consistency, the following packages should be updated

 - conga 
 - system-config-cluster (primarily for schema purposes)
Comment 11 Lon Hohberger 2010-09-22 12:55:16 EDT
The feature request which this feature request depended upon has been declined for inclusion.
Comment 12 RHEL Product and Program Management 2010-09-22 13:04:58 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.