Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 618759 - Auto-configuration of NFSv4 pseudofilesystem
Auto-configuration of NFSv4 pseudofilesystem
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
yanfu,wang
: FutureFeature
Depends On:
Blocks: 586461
  Show dependency treegraph
 
Reported: 2010-07-27 12:49 EDT by Lon Hohberger
Modified: 2016-04-26 09:50 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 586461
Environment:
Last Closed: 2010-09-21 16:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2010-07-27 12:49:49 EDT
+++ This bug was initially created as a clone of Bug #586461 +++

Description of problem:

The NFS service within cluster suite does not allow for the NFS version to be specified.  Thus the service defaults to the RHEL default of v3.

If NFSv4 is required the script resource or another customer solution must be employed.

It also stands to reason that in certain circumstances you might wish to change some of the other defaults like rsize and wsize.

So perhaps it would make sense to change the NFS agent so that any nfs configuration option could be implemented.

[some details removed for the sake of brevity]

--- Additional comment from lhh@redhat.com on 2010-07-27 10:18:38 EDT ---

In RHEL6 there is a kernel enhancement which makes this feasible - it sets up the pseudoroot namespace when the first export is fed in.  This in turn allows 'exportfs' to work largely as it does today.

Actually, we added NFSv4 support to RHEL6:

http://git.fedorahosted.org/git/?p=cluster.git;a=blob;f=rgmanager/src/resources/nfsserver.sh;h=17f472d0d21d6b53dd27afe4bce690f25d9c05d8;hb=348d5e9b4b3cd92e8739a5fc3b9e6bd2809dc722

On RHEL5, setting up the NFSv4 server requires setting up a pseudo-root file system explicitly, which is not particularly easy to do in a sane way in a cluster with more than one export.

More to the point, any work done on RHEL5 will not work on RHEL6 and vice-versa due to differences in the way NFSv4 setup is performed in those releases.  There is also no sane way to do configuration upgrade compatibility - users of a resource-agent designed for RHEL5 would have no migration path; it would be a dead-end feature.

So, we'd need the kernel enhancement from RHEL6 backported to RHEL5 before this is feasible.

--- Additional comment from lhh@redhat.com on 2010-07-27 12:44:46 EDT ---

I scoped this out with one of the developers who implemented the kernel feature.  The following packages will require changes in order for the cluster to provide a native nfsv4 agent on Red Hat Enterprise Linux 5:

 - kernel
 - nfs-utils
 - rgmanager

Additionally, for consistency, the following packages should be updated

 - conga 
 - system-config-cluster (primarily for schema purposes)
Comment 5 RHEL Product and Program Management 2010-09-21 16:24:52 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.