Bug 58653 - C++ crash without optimization (ia64)
C++ crash without optimization (ia64)
Status: CLOSED DUPLICATE of bug 58647
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-22 06:45 EST by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-22 06:45:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-01-22 06:45:08 EST
Description of Problem:
g++ crashes while compiling this file.

Version-Release number of selected component (if applicable):
gcc-3.1-0.18

How Reproducible:
100%

Steps to Reproduce:
1. c++ -c OmniIJSProxy.cpp

Actual Results:

OmniIJSProxy.cpp: In member function `bool OmniIJSProxy::rasterize(unsigned
   char*, _BitmapInfo2*, _Rectl*, BITBLT_TYPE)':
OmniIJSProxy.cpp:2060: warning: cast from pointer to integer of different size
OmniIJSProxy.cpp:2105: warning: cast from pointer to integer of different size
OmniIJSProxy.cpp: In static member function `static DeviceMedia* DeviceMedia*
   OmniIJSProxy::getCurrentMedia()::OmniIJSProxyMedia::create(char*,
   PrinterCommand*, int, int)':
OmniIJSProxy.cpp:1314: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Comment 1 Jakub Jelinek 2002-01-22 12:01:44 EST

*** This bug has been marked as a duplicate of 58647 ***

Note You need to log in before you can comment on or make changes to this bug.