Bug 58647 - gcc 3.1-0.18 crash at -O2 (C++)
gcc 3.1-0.18 crash at -O2 (C++)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 58649 58653 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-22 04:23 EST by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 06:06:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OmniIJSProxy.cpp (900.83 KB, text/plain)
2002-01-22 04:25 EST, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2002-01-22 04:23:24 EST
Description of Problem:
g++ crashes while compiling a file from Omni, if -O2 is used.  -O1 is fine.

Version-Release number of selected component (if applicable):
gcc-3.1-0.18

How Reproducible:
100%

Steps to Reproduce:
1. g++ -c -O2 OmniIJSProxy.cpp

Actual Results:
/usr/include/g++-v3/bits/locale_facets.tcc: In function `void
   std::__pad(std::ios_base&, _CharT, _CharT*, const _CharT*, int, int, bool)
   [with _CharT = char, _Traits = std::char_traits<char>]':
/usr/include/g++-v3/bits/locale_facets.tcc:2113:   instantiated from `void 
std::__pad(std::ios_base&, _CharT, _CharT*, const _CharT*, int, int, bool) 
[with _CharT = char]'
/usr/include/g++-v3/bits/ostream.tcc:633:   instantiated from 
`std::basic_ostream<char, _Traits>& std::operator<<(std::basic_ostream<char, 
_Traits>&, const char*) [with _Traits = std::char_traits<char>]'
OmniIJSProxy.cpp:165:   instantiated from here
/usr/include/g++-v3/bits/locale_facets.tcc:2101: internal error: Segmentation
   fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Additional Information:
Comment 1 Tim Waugh 2002-01-22 04:25:12 EST
Created attachment 43154 [details]
OmniIJSProxy.cpp
Comment 2 Tim Waugh 2002-01-22 10:13:59 EST
Seems to be fine with -march=i386 -mcpu=i686.
Comment 3 Jakub Jelinek 2002-01-22 11:58:38 EST
See http://gcc.gnu.org/ml/gcc-patches/2002-01/msg01499.html
Comment 4 Jakub Jelinek 2002-01-22 11:59:24 EST
*** Bug 58649 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Jelinek 2002-01-22 12:01:39 EST
*** Bug 58653 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2002-01-23 06:05:37 EST
*** Bug 58649 has been marked as a duplicate of this bug. ***
Comment 7 Tim Waugh 2002-01-23 06:06:26 EST
*** Bug 58649 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Jelinek 2002-02-01 11:22:49 EST
Fixed in gcc-3.1-0.19.

Note You need to log in before you can comment on or make changes to this bug.