Bug 586561 - shutdown of configd on windows
Summary: shutdown of configd on windows
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-wallaby-client   
(Show other bugs)
Version: Development
Hardware: All Windows
high
medium
Target Milestone: 1.3
: ---
Assignee: Robert Rati
QA Contact: Martin Kudlej
URL:
Whiteboard:
Keywords:
: 589673 (view as bug list)
Depends On: 625784
Blocks: 559596
TreeView+ depends on / blocked
 
Reported: 2010-04-27 21:13 UTC by Timothy St. Clair
Modified: 2010-10-21 18:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-21 18:45:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Timothy St. Clair 2010-04-27 21:13:07 UTC
Description of problem:
Shutdown of the configd on windows 

Version-Release number of selected component (if applicable):
win build #49 

How reproducible:
100%

Steps to Reproduce:
1. condor_off -master 
  
Actual results:
hangs or daemon hangs around

Expected results:
clean shutdown

Additional info:
There was the idea of overriding the shutdown script with our own where if the pid-to-die = configd it will drop a file and wait for clean shutdown, otherwise it will call the original method of process shutdown.

Comment 1 Pete MacKinnon 2010-05-06 17:27:03 UTC
*** Bug 589673 has been marked as a duplicate of this bug. ***

Comment 2 Pete MacKinnon 2010-06-09 23:46:31 UTC
Pushed to FH config-tools repo as windows_shutdown branch. The new pidkill.bat doesn't invoke condor_softkill but could I suppose after the sleep. Lots o' room for improvement

Comment 3 Timothy St. Clair 2010-06-10 15:46:44 UTC
Made a minor update to pidkill.bat to exit early if configd is gone. 

During my testing I had noticed various shutdown scenarios which would cause the configd to simply hang.

Step 1: open a terminal navigate to <install_path>\bin\ & execute condor_configd.py
Step 2: open a second terminal navigate to the above path and use process explorer to determine pid of condor_configd.py -> python.exe 
Step 3: type pidkill.bat <pid> 

During failure conditions you will see pidkill.bat exit and condor_configd.py will still be hanging around.

Comment 4 Robert Rati 2010-06-10 20:42:43 UTC
All issues are resolved.  The configd is able to restart condor, multiple times, via an even from wallaby.  The configd will be shutdown each time correctly as well.

Fixed in:
condor-wallaby-2.8-0.1

Comment 6 Martin Kudlej 2010-09-27 12:29:30 UTC
I've tested this on Windows 2003/XP x i386/x86_64 and it works. --> VERIFIED


Note You need to log in before you can comment on or make changes to this bug.