Bug 586568 - v7 submit fails with error
v7 submit fails with error
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.1
All Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
Caspar Zhang
:
: 609457 612319 612324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 17:38 EDT by Stephen Elia
Modified: 2010-09-21 08:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When running v7 submit, the test results are now generated correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 08:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
package.log (11.33 KB, application/octet-stream)
2010-04-28 12:32 EDT, Stephen Elia
no flags Details
report.py patch changing results rpm to allow binaries (488 bytes, patch)
2010-07-08 10:05 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Stephen Elia 2010-04-27 17:38:06 EDT
Description of problem:
Running v7 submit causes error.

Version-Release number of selected component (if applicable):
v7-1.1-23.el6

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 6 Beta
2. Install v7-1.1-23.el6 tests (including other required files)
3. Run tests (v7 plan, v7 certify, v7 submit)
  
Actual results:
When v7 submit is run I get the following error:
loaded results /var/v7/results.xml
writing results to /var/log/v7/v7-Intel_Corporation-SandyBridge_Platform-Santiago6_x86_64_results
building results rpm...
Moving the results rpm to data directory /var/v7
"cat /var/v7/package.log" no match for regular expression Wrote: (?P<rpm>[^\ ]+)$
Error: failed to generate results rpm


Expected results:
Expect tests to wrap up rpm of results.


Additional info:
Comment 1 Greg Nichols 2010-04-28 09:57:31 EDT
Please attach /var/v7/package.log
Comment 2 Stephen Elia 2010-04-28 12:32:53 EDT
Created attachment 409897 [details]
package.log
Comment 3 Stephen Elia 2010-06-10 12:39:26 EDT
This still fails with RHEL 6.0 Beta SS6 and v7-1.2-3.el6.
Comment 4 Greg Nichols 2010-07-06 10:37:15 EDT
*** Bug 609457 has been marked as a duplicate of this bug. ***
Comment 5 Greg Nichols 2010-07-07 20:44:24 EDT
*** Bug 612319 has been marked as a duplicate of this bug. ***
Comment 6 Greg Nichols 2010-07-07 20:45:00 EDT
*** Bug 612324 has been marked as a duplicate of this bug. ***
Comment 7 Greg Nichols 2010-07-08 10:05:43 EDT
Created attachment 430375 [details]
report.py patch changing results rpm to allow binaries

This patch adds a setting to the results rpm spec allowing arch-dependant binaries to be included in the results rpm.
Comment 10 Caspar Zhang 2010-09-06 04:04:14 EDT
Confirmed this bug has been fixed in >=R16, Move to 'VERIFIED'
Comment 12 errata-xmlrpc 2010-09-20 08:14:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html
Comment 13 Jaromir Hradilek 2010-09-21 08:39:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When running v7 submit, the test results are now generated correctly.

Note You need to log in before you can comment on or make changes to this bug.