Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586577 - please document 'ignoredisk --only-use'
please document 'ignoredisk --only-use'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Installation_Guide (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ruediger Landmann
ecs-bugs
: Documentation
Depends On:
Blocks: 601968 601969
  Show dependency treegraph
 
Reported: 2010-04-27 17:59 EDT by Jeff Bastian
Modified: 2012-04-12 21:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 601968 (view as bug list)
Environment:
Last Closed: 2012-04-12 21:05:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for Kickstart2.xml (1.33 KB, application/octet-stream)
2010-06-24 21:36 EDT, Jason Taylor
no flags Details

  None (edit)
Description Jeff Bastian 2010-04-27 17:59:55 EDT
Description of problem:
A new --only-use option was added to the kickstart ignoredisk command for bug
318351, however, this new option is not documented in the Installation Guide.  This option tells anaconda to only use the specified disk(s), e.g.
  ignoredisk --only-use=sda

http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Installation_Guide-en-US/s1-kickstart2-options.html
Comment 1 Jeff Bastian 2010-04-27 18:01:14 EDT
See bug 586576 for corresponding documentation in /usr/share/doc/anaconda-*/kickstart-docs.txt
Comment 2 Jason Taylor 2010-06-24 21:36:32 EDT
Created attachment 426738 [details]
patch for Kickstart2.xml

patch for Kickstart2.xml
Comment 3 RHEL Product and Program Management 2010-08-09 14:36:28 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2010-09-06 19:16:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Ruediger Landmann 2010-12-20 23:14:07 EST
Thanks Jason for the patch.

Fixed in build 3.1-9:

=====================
ignoredisk (optional)
    Causes the installer to ignore the specified disks. This is useful if you use autopartition and want to be sure that some disks are ignored. For example, without ignoredisk, attempting to deploy on a SAN-cluster the kickstart would fail, as the installer detects passive paths to the SAN that return no partition table. The --only-use option specifies that only the disks listed will be used during installion.
    The ignoredisk option is also useful if you have multiple paths to your disks.
    The syntax is:

    ignoredisk --drives=drive1,drive2,...

    where driveN is one of sda, sdb,..., hda,... etc.

        *
          --only-use — specifies a list of disks for the installer to use. All other disks are ignored. For example, to use disk sda during installation and ignore all other disks:

          ignoredisk --only-use=sda
Comment 8 RHEL Product and Program Management 2011-01-11 14:53:43 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-01-11 17:38:03 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 10 RHEL Product and Program Management 2011-05-31 09:08:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.