Bug 586592 - Bootup stops on udev but finally timeouts and continues
Summary: Bootup stops on udev but finally timeouts and continues
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mdadm   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Jan Ščotka
URL:
Whiteboard:
Keywords:
: 595095 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 23:07 UTC by Mikolaj Kucharski
Modified: 2010-11-11 14:51 UTC (History)
3 users (show)

Fixed In Version: mdadm-3.1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 14:51:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My kickstart file for this install (3.04 KB, text/plain)
2010-04-27 23:11 UTC, Mikolaj Kucharski
no flags Details
Bootup log file (33.07 KB, text/plain)
2010-04-27 23:24 UTC, Mikolaj Kucharski
no flags Details

Description Mikolaj Kucharski 2010-04-27 23:07:55 UTC
Description of problem:
Bootup stops for tens of seconds after udev timeouts.


Version-Release number of selected component (if applicable):
udev-147-2.6.el6.x86_64


How reproducible:
Install RHEL 6.0 Beta with software raid:

Personalities : [raid1]
md5 : active raid1 sda5[0] sdb5[1]
      967846780 blocks super 1.1 [2/2] [UU]
      [=>...................]  resync =  7.2% (70071552/967846780) finish=11580.1min speed=1291K/sec
      bitmap: 8/8 pages [32KB], 65536KB chunk

md3 : active raid1 sda2[0] sdb2[1]
      4194296 blocks super 1.1 [2/2] [UU]
      bitmap: 0/1 pages [0KB], 65536KB chunk

md2 : active raid1 sda1[0] sdb1[1]
      4194296 blocks super 1.1 [2/2] [UU]

md1 : active raid1 sda3[0] sdb3[1]
      524276 blocks super 1.0 [2/2] [UU]

unused devices: <none>


Actual results:
Bootup is slow/delayed.


Expected results:
Bootup should be immediate.

Comment 1 Mikolaj Kucharski 2010-04-27 23:11:04 UTC
Created attachment 409613 [details]
My kickstart file for this install

This file was used to install my testing RHEL 6.0 beta server.

Comment 3 Mikolaj Kucharski 2010-04-27 23:24:02 UTC
Created attachment 409614 [details]
Bootup log file

You can see error from udev initscript in this log file.

Comment 4 RHEL Product and Program Management 2010-04-28 00:15:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Harald Hoyer 2010-04-28 06:37:01 UTC
most probable an mdadm udev rules issue..

Comment 6 Doug Ledford 2010-05-25 21:18:57 UTC
Beta1 included mdadm-3.1.1-0.gcd9a8b5.5.el6.  This is a known issue with that version of mdadm that was fixed in mdadm-3.1.2.  Current snapshots include mdadm-3.1.2-10.el6 and are known to resolve this issue.

Comment 7 Doug Ledford 2010-07-22 17:18:33 UTC
*** Bug 595095 has been marked as a duplicate of this bug. ***

Comment 8 Gordan Bobic 2010-07-22 17:33:22 UTC
I can confirm that I haven't observed this issue re-occurring with beta 2.

Comment 10 releng-rhel@redhat.com 2010-11-11 14:51:20 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.