Bug 586596 - RFE: SquirrelMail for RHEL 6.0
Summary: RFE: SquirrelMail for RHEL 6.0
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: RHEL Product and Program Management
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
: 587880 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-27 23:39 UTC by Pumpino
Modified: 2018-12-02 18:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 14:47:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pumpino 2010-04-27 23:39:30 UTC
Description of problem:

No SquirrelMail package is available for RHEL 6.

How reproducible:

No package available in the repo.

Expected results:

SquirrelMail is perhaps the most popular web-based email software used by businesses and hosting companies. Why has it been removed from RHEL 6?

I attempted to install SquirrelMail 1.4.19 and 1.4.20 RPMs for Fedora 12, but these failed to install, reporting that it depended on package php-mbstring, but php-mbstring isn't available to install.

I attempted to install SquirrelMail 1.4.20 from the tarball but it did not function when I entered the appropriate path into Firefox.

Comment 2 RHEL Product and Program Management 2010-04-28 01:15:17 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 RHEL Product and Program Management 2010-04-28 05:31:32 UTC
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.

Comment 4 Bill Nottingham 2010-05-05 18:46:08 UTC
*** Bug 587880 has been marked as a duplicate of this bug. ***

Comment 9 Siddharth Nagar 2010-06-02 14:42:12 UTC
After careful consideration, we have made the decision to not approve this request for including SquirrelMail in RHEL 6. In general, these decisions are based on insufficient business justification and lack of relevance to the larger RHEL platform community. We feel that it is most appropriate for this application to be part of EPEL (Extra Packages for Enterprise Linux).

Comment 10 RHEL Product and Program Management 2010-06-02 14:47:43 UTC
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

Comment 11 Somasree Mal 2014-10-21 09:22:04 UTC
In RHEL6.4, squirrelmail is running fine, I've used EPEL, rpmfusion free and non-free for EL6 in order to install squirrelmail and php-mbstring packages.
An error occurs "ERROR: Could not
complete request.
Query: SELECT "INBOX"
Reason Given: [SERVERBUG] Internal error occurred" refer server log for more information,from maillog I found the error "imap(user): Error: chown(/home/user/mail/.imap/INBOX, -1, 12(mail)) failed: Operation not permitted (egid=1000(user), group based on /var/mail/user)"  and this is due to dovecot issue, for that I do the following steps:

1) I edit dovecot configuration file:

In /etc/dovecot/dovecot.conf, type

protocol imap {
mail_location = mbox:~/mail:INBOX=/var/mail/%u
}

2) # chmod 0600 /var/mail/$user after adding each user who need to access email over imap

or, 
a) in /etc/dovecot/conf.d/10-mail.conf
   uncomment the line mail_access_groups = mail

and
b) add user who need to access email over imap to mail group

So, I think this is not a bug.


Note You need to log in before you can comment on or make changes to this bug.