Bug 586615 - [abrt] crash in evince-2.30.1-1.fc13: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
[abrt] crash in evince-2.30.1-1.fc13: Process /usr/bin/evince was killed by s...
Status: CLOSED DUPLICATE of bug 586343
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
abrt_hash:4436f397b3422d18d824700f789...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-27 20:52 EDT by Petr Bohac
Modified: 2010-04-28 11:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-28 11:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.57 KB, text/plain)
2010-04-27 20:52 EDT, Petr Bohac
no flags Details
PDF file causing SEGV (1.37 MB, application/pdf)
2010-04-27 20:55 EDT, Petr Bohac
no flags Details

  None (edit)
Description Petr Bohac 2010-04-27 20:52:55 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: evince file:///tmp/Meteorologick%C3%A9%20zpr%C3%A1vy%205_04.pdf
comment: Evince crash with segmentation fault when trying to open PDF file (attached to this report). It happens only with this PDF, others are OK. Maybe this one is not well formed, but it still should not cause SEGV.
component: evince
executable: /usr/bin/evince
global_uuid: 4436f397b3422d18d824700f789e4bf604ee01cc
kernel: 2.6.33.2-57.fc13.x86_64
package: evince-2.30.1-1.fc13
rating: 4
reason: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. open pdf file (see attachment)
Comment 1 Petr Bohac 2010-04-27 20:52:58 EDT
Created attachment 409635 [details]
File: backtrace
Comment 2 Petr Bohac 2010-04-27 20:55:30 EDT
Created attachment 409637 [details]
PDF file causing SEGV
Comment 3 Petr Bohac 2010-04-27 21:44:59 EDT
Found where was the problem. Directory "~/.gnome2/evince" was missing. Don't how I previously managed to open some other PDF (maybe from console as another user). Manually creating the directory will fix this issue. Attached PDF has no relevance to this, so can be removed.

When i tried to open evince from console I get this warning message:
** (evince:3773): WARNING **: Error creating last_settings file: Chyba při otevírání souboru "/home/bohyn/.gnome2/evince/last_settings": Adresář nebo soubor neexistuje

In English something like:
Error when opening file "/home/bohyn/.gnome2/evince/last_settings": File or directory does not exists
Comment 4 Marek Kašík 2010-04-28 11:31:14 EDT

*** This bug has been marked as a duplicate of bug 586343 ***

Note You need to log in before you can comment on or make changes to this bug.