This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 586343 - [abrt] crash in evince-2.30.1-1.fc13: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
[abrt] crash in evince-2.30.1-1.fc13: Process /usr/bin/evince was killed by s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
abrt_hash:5adca7369b609d5b1ac28816f16...
: Triaged
: 586345 586574 586584 586615 586786 586952 586963 586964 586969 586987 587046 587076 587077 587100 587144 587162 587195 587453 587460 587673 587708 587832 587985 588329 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-27 07:17 EDT by Pavel Ondračka
Modified: 2013-01-10 00:51 EST (History)
39 users (show)

See Also:
Fixed In Version: evince-2.30.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 587162 (view as bug list)
Environment:
Last Closed: 2010-04-30 19:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (9.62 KB, text/plain)
2010-04-27 07:17 EDT, Pavel Ondračka
no flags Details

  None (edit)
Description Pavel Ondračka 2010-04-27 07:17:37 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: evince /home/Paulie/Dokumenty/plosint.1_pr.pdf
component: evince
executable: /usr/bin/evince
global_uuid: 5adca7369b609d5b1ac28816f162f9fbae4570aa
kernel: 2.6.33.2-57.fc13.i686
package: evince-2.30.1-1.fc13
rating: 4
reason: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Pavel Ondračka 2010-04-27 07:17:39 EDT
Created attachment 409440 [details]
File: backtrace
Comment 2 Pavel Ondračka 2010-04-27 07:21:02 EDT
[Paulie@SatelliteProA100 ~]$ evince

** (evince:7613): WARNING **: Error creating last_settings file: Chyba při otevírání souboru "/home/Paulie/.gnome2/evince/last_settings": Adresář nebo soubor neexistuje

Neoprávněný přístup do paměti (SIGSEGV) (core dumped [obraz paměti uložen])
Comment 3 Danny Stieben 2010-04-27 20:03:51 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
Tried to open a PDF
Comment 4 Rui Matos 2010-04-28 11:19:40 EDT
I don't really have time to debug this further now, but just doing a

$ mkdir ~/.gnome2/evince

works around this crash.
Comment 5 Marek Kašík 2010-04-28 11:30:16 EDT
*** Bug 586345 has been marked as a duplicate of this bug. ***
Comment 6 Marek Kašík 2010-04-28 11:30:34 EDT
*** Bug 586574 has been marked as a duplicate of this bug. ***
Comment 7 Marek Kašík 2010-04-28 11:30:48 EDT
*** Bug 586584 has been marked as a duplicate of this bug. ***
Comment 8 Marek Kašík 2010-04-28 11:31:14 EDT
*** Bug 586615 has been marked as a duplicate of this bug. ***
Comment 9 Marek Kašík 2010-04-28 11:31:28 EDT
*** Bug 586786 has been marked as a duplicate of this bug. ***
Comment 10 Marek Kašík 2010-04-28 11:31:45 EDT
*** Bug 586952 has been marked as a duplicate of this bug. ***
Comment 11 Marek Kašík 2010-04-28 11:32:05 EDT
*** Bug 586963 has been marked as a duplicate of this bug. ***
Comment 12 Marek Kašík 2010-04-28 11:32:18 EDT
*** Bug 586964 has been marked as a duplicate of this bug. ***
Comment 13 Marek Kašík 2010-04-28 11:32:33 EDT
*** Bug 586969 has been marked as a duplicate of this bug. ***
Comment 14 Carl G. 2010-04-28 11:34:05 EDT
mkdir ~/.gnome2/evince
touch ~/.gnome2/evince/last_settings

Will fix this issue.

Evince should be more tolerant / create the dir if it doesn't exist upon startup.
Comment 15 Marek Kašík 2010-04-28 11:50:12 EDT
*** Bug 586987 has been marked as a duplicate of this bug. ***
Comment 16 Rocco Rossi 2010-04-28 14:12:15 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open PDF file.
2.
3.


Comment
-----
Evince crashes now on any file one opens! A disaster!
Comment 17 scumbag 2010-04-28 16:10:52 EDT
The workaround that Carl G post in the comment #14 fix the issue.

The old version 2.30.0-4 don't crash, so a downgrade also works.
Comment 18 Miloš Komarčević 2010-04-28 17:37:48 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Double-click on a PDF file with a long path


Comment
-----
Filename seems to be truncated.

Evince should fail more gracefully.
Comment 19 Cia Watson 2010-04-28 22:10:21 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Double-click a pdf file to open it and view.
2. It gives me a message evince has crashed.
3.
Comment 20 Dave Jeffery 2010-04-29 04:01:23 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Opened Nautilus File Browser
2.Browsed the contents of a DVD+R disc
3.Double clicked on thinkpython.pdf (on the DVD+R disc)
Comment 21 Marek Kašík 2010-04-29 05:48:40 EDT
*** Bug 587076 has been marked as a duplicate of this bug. ***
Comment 22 Marek Kašík 2010-04-29 05:48:50 EDT
*** Bug 587077 has been marked as a duplicate of this bug. ***
Comment 23 Marek Kašík 2010-04-29 05:49:01 EDT
*** Bug 587100 has been marked as a duplicate of this bug. ***
Comment 24 Adam Williamson 2010-04-29 06:27:41 EDT
Confirming I see this too. Reproducer for me is just to run it on any PDF.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Marek Kašík 2010-04-29 06:30:36 EDT
*** Bug 587195 has been marked as a duplicate of this bug. ***
Comment 26 Marek Kašík 2010-04-29 09:03:36 EDT
*** Bug 587144 has been marked as a duplicate of this bug. ***
Comment 27 Marek Kašík 2010-04-29 09:03:50 EDT
*** Bug 587162 has been marked as a duplicate of this bug. ***
Comment 28 Marek Kašík 2010-04-29 09:31:02 EDT
Hi,

I backported patch from gnome bug #617154. The patch fixes this problem for me. The tag of the build is evince-2.30.1-2.fc13.

Thank you all for your information

Marek
Comment 29 Fedora Update System 2010-04-29 09:36:05 EDT
evince-2.30.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/evince-2.30.1-2.fc13
Comment 30 flashl 2010-04-29 14:49:27 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open pdf file using document viewer in evloution 
2.
3.


Comment
-----
Opening pdf to view
Comment 31 Stéphane Maniaci 2010-04-29 17:10:53 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I don't really know
2.
3.


Comment
-----
I just download a PDF file and I think it crashed when I tried to open it.
Comment 32 Marek Kašík 2010-04-30 03:07:09 EDT
*** Bug 587460 has been marked as a duplicate of this bug. ***
Comment 33 Marek Kašík 2010-04-30 06:24:19 EDT
*** Bug 587453 has been marked as a duplicate of this bug. ***
Comment 34 Marek Kašík 2010-04-30 06:24:35 EDT
*** Bug 587046 has been marked as a duplicate of this bug. ***
Comment 35 Boricua 2010-04-30 10:06:41 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Select a .pdf document for opening with evince
2.Click the document
3.Evince crashes.


Comment
-----
This behavior happens even if I try to open evince from the main menu.
Comment 36 Marek Kašík 2010-04-30 10:35:17 EDT
*** Bug 587673 has been marked as a duplicate of this bug. ***
Comment 37 Fedora Update System 2010-04-30 13:20:44 EDT
evince-2.30.1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evince'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/evince-2.30.1-2.fc13
Comment 38 leigh scott 2010-04-30 13:22:12 EDT
Updating to evince-2.30.1-2.fc13 fixes the issue here.
Comment 39 Garland Binns 2010-04-30 14:30:59 EDT
Package: evince-2.30.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Double-click on any PDF and try to open it.


Comment
-----
This issue prevents me from opening any PDFs.
Comment 40 Fedora Update System 2010-04-30 19:37:07 EDT
evince-2.30.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 41 Marek Kašík 2010-05-03 03:46:58 EDT
*** Bug 587708 has been marked as a duplicate of this bug. ***
Comment 42 Marek Kašík 2010-05-03 03:47:14 EDT
*** Bug 587832 has been marked as a duplicate of this bug. ***
Comment 43 Marek Kašík 2010-05-03 03:47:53 EDT
*** Bug 587985 has been marked as a duplicate of this bug. ***
Comment 44 Marek Kašík 2010-05-03 10:10:24 EDT
*** Bug 588329 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.