Bug 58676 - Unable to handle Kernel NULL Pointer dereference at virtual Address 00000000
Unable to handle Kernel NULL Pointer dereference at virtual Address 00000000
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-22 13:38 EST by Dave Gedeon
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 15:27:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Gedeon 2002-01-22 13:38:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 95; DigExt)

Description of problem:
After installing RedHat Linux 7.2 the immediate following boot fails, the 
screen to too fast to gather when it began to fail - all I can write is what is 
left on the screen.  I have disabled the USB and ONBoard Sound Chips(whatever) 
on the BIOS and pulled out the SCSI and Network cards.   It still will not boot 
successfully.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on Computer
2. Select Linux from Lilo Prompts
3. Most the time it will get somewhere past "Checking For New Hardware" before 
it Kernel Panics.
	

Actual Results:  Never received a Login prompt.

Additional info:

Checking for New Hardware
  |
  |
code: 89 08 eb 2c 90 8d 74 26 00 8b 46 08 8b 51 04 8b 58 04 8b 01
<1> Unable to handle Kernel Null Pointer dereference at virtual address 00000000
printing eip
c0114244
*pde=00000000
Oops: 0000
cpu: 0
EIP: 0010:[<c0114244>]
EFLAGS:00010086
eax: c633ec88 ebx:00000000 ecx:00000001 edx:00000003
esi: c13b3340 edi:00000001 ebp:c0259ecc esp:c025qeb4
ds:  0018   es 0018   ss  0018
Process Swapper(pid:0, Stackpage=c059000)
Stack:00000086  00000003  c63ec88 c63ec40  c13b3340 00000008 00000001 c0180143
  c633ec40 00000001 c13b3340 c13c4080 00000246 c02e1ae0 c018ace8
c13b3340
  00000001 c02eid44 012e1c54 00c13b3340 c02eic54 c0194d80 00000001
call trace:[<c018143>][<c018ace8>] c0194d80 c018c630 c0194d10
 c01082aa c01084s8 c0105390 c0105390  c0208760 c0105390
 c0105390 c01053b3 c0105432 c0105000  c020e760
Code 8b 13 0f 0d 02 eb 6b 90 8b 74 26 00 8b 4b fc 8b 01 85 45 ec
<0> Kernal Panic: Aiee, Killing Interrupt Handler
    In interrupt Handler - not syncing
<<<  If I typed everything perfectly! >>>
Comment 1 Arjan van de Ven 2002-01-22 14:27:43 EST
Is this an athlon machine ?
Comment 2 Dave Gedeon 2002-01-23 09:43:16 EST
Sorry to not have put this in originally.  Also: This is not a crisis!  It is 
my new home PC.

Yes - The CPU is an AMD Athlon 1.2 GHz.
Mother Board: SY-K7VTA-Pro Version 2AA5 ( Soyo )
              Socket 462 For AMD Athlon
              VIA KT133A AGP 266MHz Front Side Bus.
Audio Controller: VIA AC '97 Audio Controller (WDM)
VIA VT83C572/VT82C586 PCI to USB.
NIC: D-Link DFE-530TX+ PCI Adapter
VIA Bus Master PCI IDE Controller
Vidio: Nvidia RIVA TNT2 Model 64 Pro ( 32MB Memory ).
Comment 3 Arjan van de Ven 2002-01-23 09:47:46 EST
Ok, would you mind looking at bug 55040 and see if the workaround in that works
for you ?
Comment 4 Dave Gedeon 2002-01-23 12:21:44 EST
I received your message about the "noathlon" option.  I will try it when I get 
home tonight.  My only issue - now - is ; I prefer Lilo ( I'm used to it since  
Biltmore (4.2) and Appolo ( 5.2 ):  could you E-mail me a quick update as to 
how to use the "noathlon" in it?
Thanks again for your time ( and patience! ).
Comment 5 Arjan van de Ven 2002-01-23 12:24:46 EST
sure
you can test it in lilo simple: just type "linux noathlon" on the lilo prompt.
That should work. If it does, you need to add the following line to the
lilo.conf section:

append "noathlon"

or if there already is an append line you should add noathlon to that line,
separated from the other options by a space. Don't forget to run "lilo"
afterwards to activate the change.
Comment 6 Dave Gedeon 2002-01-24 15:27:19 EST
Now I am Impressed!!!  The Install of 7.2 went perfectly - no runs no errors!
Obviously - this error bug#58676 can be closed.

Thanks again  
  Dave.
Comment 7 Arjan van de Ven 2002-01-24 15:35:11 EST
If you install the yesterday released erratakernel the biosbug is worked around
and the athlon kernel will just work....

Note You need to log in before you can comment on or make changes to this bug.