Bug 586763 - wrong ne.orth
wrong ne.orth
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 586898
  Show dependency treegraph
 
Reported: 2010-04-28 06:36 EDT by Akira TAGOH
Modified: 2012-06-11 08:18 EDT (History)
6 users (show)

See Also:
Fixed In Version: fontconfig-2.9.91-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 586898 (view as bug list)
Environment:
Last Closed: 2012-06-11 08:18:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 24729 None None None Never

  None (edit)
Description Akira TAGOH 2010-04-28 06:36:00 EDT
Description of problem:
madan-fonts is supposed to work for Nepali font though, it doesn't have enough glyph coverage in fontconfig.

Version-Release number of selected component (if applicable):
madan-fonts-2.000-2.fc13.noarch

How reproducible:
always

Steps to Reproduce:
1.fc-match -v "Madan"|grep -E "        lang"|grep ne
2.
3.
  
Actual results:
No output

Expected results:
the lang spec should contains ne.

Additional info:
Comment 1 Akira TAGOH 2010-04-28 06:36:36 EDT
This is raised during the testing of Bug#578041.
Comment 2 Parag Nemade 2010-05-20 02:53:29 EDT
This is because of fontconfig ne.orth issue. This problem is already reported
in upstream https://bugs.freedesktop.org/show_bug.cgi?id=24729

So we are waiting for long in upstream but no fixes yet.
Comment 3 Bug Zapper 2010-07-30 07:29:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Parag Nemade 2011-11-10 00:09:24 EST
ping behdad

moving this to F16
Comment 5 Behdad Esfahbod 2011-11-10 09:41:33 EST
I'm not involved in Fedora anymore.
Comment 6 Akira TAGOH 2011-11-10 20:43:26 EST
guess Parag was asking because you are still the owner of the fontconfig package in Fedora :)
Comment 7 Fedora Admin XMLRPC Client 2012-01-10 10:42:34 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Pravin Satpute 2012-02-14 10:12:52 EST
- This is resolved in upstream but nothing yet in Fedora.

- This is part of Fedora 17 feature
https://fedoraproject.org/wiki/Features/Additional_Indic_Langs
Comment 9 Fedora Admin XMLRPC Client 2012-03-21 21:38:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Update System 2012-03-23 02:58:11 EDT
fontconfig-2.8.0-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fontconfig-2.8.0-6.fc17
Comment 11 Pravin Satpute 2012-03-29 06:19:23 EDT
still present.
Comment 12 Akira TAGOH 2012-03-29 07:48:25 EDT
(In reply to comment #11)
> still present.

Does that mean you can also still see this problem on even 2.9.0?
Comment 13 Pravin Satpute 2012-03-29 08:23:46 EDT
Yes, sorry i have not written much here. Have written more detail on upstream bug id http://bugs.freedesktop.org/show_bug.cgi?id=24729 submitted latest patch there as well.

Actually parag's patch never got committed in uptream.

This bug not affecting "Additional language" feature, so its fine if it takes more time.
Comment 14 Fedora Update System 2012-04-11 22:16:20 EDT
fontconfig-2.8.0-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Akira TAGOH 2012-06-11 08:18:54 EDT
should be fixed in fontconfig-2.9.91-1.fc18

Note You need to log in before you can comment on or make changes to this bug.