Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 586873 - cannot install gcc-c++, dependency problem
cannot install gcc-c++, dependency problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-28 09:25 EDT by Yves Dorfsman
Modified: 2014-03-25 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-02 10:51:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yves Dorfsman 2010-04-28 09:25:34 EDT
Description of problem:
gcc-c++ doesn't install.

Version-Release number of selected component (if applicable):


How reproducible:
very

Steps to Reproduce:
1. yum install gcc-c++
2.
3.
  
Actual results:
yum install gcc-c++
updates-testing/metalink                                 |  15 kB     00:00     
updates-testing                                          | 4.4 kB     00:00     
updates-testing/primary_db                               | 1.1 MB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc-c++.i686 0:4.4.3-16.fc13 set to be updated
--> Processing Dependency: libstdc++ = 4.4.3-16.fc13 for package: gcc-c++-4.4.3-16.fc13.i686
--> Processing Dependency: libstdc++-devel = 4.4.3-16.fc13 for package: gcc-c++-4.4.3-16.fc13.i686
--> Running transaction check
---> Package gcc-c++.i686 0:4.4.3-16.fc13 set to be updated
--> Processing Dependency: libstdc++ = 4.4.3-16.fc13 for package: gcc-c++-4.4.3-16.fc13.i686
---> Package libstdc++-devel.i686 0:4.4.3-16.fc13 set to be updated
--> Processing Dependency: libstdc++(x86-32) = 4.4.3-16.fc13 for package: libstdc++-devel-4.4.3-16.fc13.i686
--> Finished Dependency Resolution
Error: Package: libstdc++-devel-4.4.3-16.fc13.i686 (fedora)
           Requires: libstdc++(x86-32) = 4.4.3-16.fc13
           Installed: libstdc++-4.4.3-18.fc13.i686 (@updates-testing)
           Available: libstdc++-4.4.3-16.fc13.i686 (fedora)
Error: Package: gcc-c++-4.4.3-16.fc13.i686 (fedora)
           Requires: libstdc++ = 4.4.3-16.fc13
           Installed: libstdc++-4.4.3-18.fc13.i686 (@updates-testing)
           Available: libstdc++-4.4.3-16.fc13.i686 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
gcc-c++ to install

Additional info:
Comment 1 Jakub Jelinek 2010-04-30 08:40:35 EDT
Probably some mirror not fully updated or something similar.  Try again?
Comment 2 Yves Dorfsman 2010-05-02 10:51:43 EDT
Thanks - unfortunately bug https://bugzilla.redhat.com/show_bug.cgi?id=583223 was too much of an issue for me, so I had to re-build with FC12. I'll re-visit FC13 a bit later. I'll close this one for now.
Comment 3 Sid Boyce 2014-03-25 22:31:46 EDT
This bug is a show stopper for me as it prevents me building needed applications.
Hardware is Pandaboard a4.
Same result on 2 different SD card installs.
Fedora-XFCE-VFAT-panda-20-Beta-5-sda.raw.xz

"yum install" of any of the packages below fail.
# rpm -q arm-boot-config
arm-boot-config-0.62-1.fc20.armv7hl

---> Package glibc-devel.armv7hl 0:2.18-11.fc20 will be installed
--> Processing Dependency: glibc = 2.18-11.fc20 for package: glibc-devel-2.18-11.fc20.armv7hl
---> Package glibc-headers.armv7hl 0:2.18-11.fc20 will be installed
--> Processing Dependency: glibc = 2.18-11.fc20 for package: glibc-headers-2.18-11.fc20.armv7hl
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.18-11.fc20.armv7hl
--> Processing Dependency: kernel-headers for package: glibc-headers-2.18-11.fc20.armv7hl

Packages skipped because of dependency problems:
    cpp-4.8.2-7.fc20.armv7hl from updates
    gcc-4.8.2-7.fc20.armv7hl from updates
    glibc-devel-2.18-11.fc20.armv7hl from fedora
    glibc-devel-2.18-12.fc20.armv7hl from updates
    glibc-headers-2.18-11.fc20.armv7hl from fedora
    glibc-headers-2.18-12.fc20.armv7hl from updates
    libatomic-4.8.2-7.fc20.armv7hl from updates
    libmpc-1.0.1-2.fc20.armv7hl from fedora
[root@panda ~]# uname -r
3.9.5-301.fc19.armv7hl

Note You need to log in before you can comment on or make changes to this bug.