Bug 58738 - serial install doesn't leave a way to log in to the serial console
serial install doesn't leave a way to log in to the serial console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Alexandre Petit-Bianco
Brock Organ
:
: 58995 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 16:18 EST by Jeff Wiedemeier
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-22 12:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Wiedemeier 2002-01-23 16:18:20 EST
Description of Problem:

After doing a serial install, there is
	1) no aboot.conf entry for the serial console (console=ttyS0 without
console=tty0)
	2) no *getty process running on the serial port
	3) no /etc/securetty entry for ttyS0 to allow root login on the serial console

Version-Release number of selected component (if applicable):

Red Hat Linux release 7.1.90 (Roswell)

How Reproducible:

Very

Steps to Reproduce:
1. Perform a serial installation
2. Try to boot and log in on the serial console 

Actual Results:

Using installed aboot.conf entries, kernel messages can be directed to ttyS0,
but not userspace messages (i.e. boot messages once init has started).
There is now way to log in on the serial console

Expected Results:

To be able to send all console messages to ttyS0 and login in as user/root on
serial console

Additional Information:

7.1 installed mgetty, ran it on ttyS0, and added ttyS0 to /etc/securetty with a
serial install
7.1 with a serial install also had a console=ttyS0 entry in the installed
aboot.conf
Comment 1 Matt Wilson 2002-01-23 20:14:05 EST
2) and 3) should be fixed with modifications to bootloader.py to append
console=ttyS0 if flags.serial is set, as kudzu should detect that /dev/console
is a serial terminal on bootup and add the getty, etc.
Comment 2 john.goshdigian 2002-01-27 15:09:47 EST
A serail line (ttyS0) only option needs to be in aboot.conf on both the install
CD and on the target install system disk. DS20L systems do not have a graphics
card
Comment 3 Diego Novillo 2002-02-08 14:37:30 EST
*** Bug 58995 has been marked as a duplicate of this bug. ***
Comment 4 Diego Novillo 2002-02-22 12:36:50 EST
Fixed in RC1.
Comment 5 Beth Uptagrafft 2002-03-13 09:53:45 EST
I'm closing this case because it was fixed in the Feb 22 delivery.  Please let 
us know if you still see any problems with this issue.

Note You need to log in before you can comment on or make changes to this bug.