Bug 58739 - GNOME panel crashes when "KDE menus" item highlighted
GNOME panel crashes when "KDE menus" item highlighted
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Beth Uptagrafft
:
: 59110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-23 16:44 EST by harry.heinisch
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-31 15:21:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for a bad call from gnome libs (885 bytes, application/x-gzip)
2002-03-29 16:28 EST, Michal Jaegermann
no flags Details

  None (edit)
Description harry.heinisch 2002-01-23 16:44:42 EST
Description of Problem: "Everything" install from alpha-7.2-beta1, running
on a DS20E with Matrox Millennium II graphics. When running XFree86 under
the GNOME desktop, popping the Main menu (under the foot icon) and putting the
cursor over the "KDE menus" item in the Main menu, causes an Error box to pop
up detailing that Application "panel" has crashed due to segmentation fault.


Version-Release number of selected component (if applicable): alpha-7.2-beta1


How Reproducible: every time the KDE menus item is highlighted, as per the
description of the problem above


Steps to Reproduce:
1. 
2. 
3. 

Actual Results: Panel crashes, then is respawned, so as long as you avoid
the KDE menus item, everything works fine.


Expected Results: should see some KDE menus :-)


Additional Information: (JAE) I believe this is not graphics card-specific,
as it has also happened with the ELSA card as well.
Comment 1 Beth Uptagrafft 2002-02-11 17:49:37 EST
59110 also reports this same problem.
Comment 2 Beth Uptagrafft 2002-02-11 17:51:34 EST
*** Bug 59110 has been marked as a duplicate of this bug. ***
Comment 3 Havoc Pennington 2002-03-13 12:44:58 EST
Doesn't happen on Intel, need to try to reproduce for ia64/s390.

I'm told we don't need to fix this for the Alpha port, so am only considering it
for Hampton.
Comment 4 Havoc Pennington 2002-03-18 12:29:42 EST
Punting from Hampton, gnome-panel is rewritten for the release after, so 
this bug goes away with GNOME 2.
Comment 5 Michal Jaegermann 2002-03-29 16:26:07 EST
Do you imply that Red Hat 7.2 for Alpha will get Gnome 2 without any testing
whatsoever?  You may surprise me in many ways but somehow this is hard to
believe.  This will not help very much anyway if interfaces will be treated
with the same cavalier attitude.

Anyway, here is the real problem, and a fix, and it is exactly like
predicted in my original report #59110.  Function 'iconv' is declared
in /usr/include/iconv.h as
size_t iconv (iconv_t , char **, size_t *, char **, size_t *);.
'libgnome' is passing there instead pointers to objects of int size.
You can get away with such bugs if these sizes happen to differ as
called functions scribbles at random over a stack of a caller and shit
will likely happen.  Forcing spurious conversions on a return value from
'strlen' is also not so hot idea.

Here is a fix.


--- gnome-libs-1.2.13/libgnome/gnome-dentry.c~  Fri Mar 29 12:29:52 2002
+++ gnome-libs-1.2.13/libgnome/gnome-dentry.c   Fri Mar 29 13:30:47 2002
@@ -1074,7 +1074,7 @@
        }
        if (fd != (iconv_t)-1) {
                gchar *pout, *pin, *str;
-               gint len, ib, ob;
+               size_t len, ib, ob;

                len = strlen (value);

I attach also changes to a spec file and this patch with a white
space intact. :-)  After modifications no traces of a problem with
any KDE menus whatsover.
Comment 6 Michal Jaegermann 2002-03-29 16:28:45 EST
Created attachment 51425 [details]
Fix for a bad call from gnome libs
Comment 7 Havoc Pennington 2002-03-31 15:21:25 EST
Thanks, Compaq already provided the above size_t patch even,I was planning to
integrate into Hampton but had forgotten. 
There is no Hampton 64-bit beta available right now though,
so low priority.
Comment 8 Havoc Pennington 2002-04-09 17:39:15 EDT
gnome-libs 1.4.1.2.90-12 fixes
Comment 9 Phil Copeland 2002-04-22 12:21:46 EDT
Erm,.. very nice Havoc,... unfortunately that was the 7.3 tree 8)

I've reapplied the patch to gnome-libs-1.2.13-16 and renamed th package to
gnome-libs-1.2.13-16a.src.rpm
(/mnt/redhat/beehive/comps/dist/7.2-alpha/gnome-libs/1.2.13-16a/SRPMS)
Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.