Bug 59110 - gnome panel regularly bombs
gnome panel regularly bombs
Status: CLOSED DUPLICATE of bug 58739
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Beth Uptagrafft
Beth Uptagrafft
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-30 22:05 EST by Michal Jaegermann
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-31 22:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2002-01-30 22:05:51 EST
Description of Problem:

I can reliably crash 'panel' on a GNOME desktop by stopping a mouse
on "KDE menus".  This is regardless if I am bringing up this menu
from a GNOME foot or with a right mouse button on "free" panel space.
Using any other menu entry but this particular one does not have
such effects.

In a bug-buddy window one can find after such incident:

(no debugging symbols found)...0x20000a2f380 in wait4@@GLIBC_2.1 ()
   from /lib/libc.so.6.1
#0  0x20000a2f380 in wait4@@GLIBC_2.1 () from /lib/libc.so.6.1
#1  0x20000a2f2fc in __libc_waitpid (pid=2025, stat_loc=0x11fffe930, options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:26
#0  0x20000a2f380 in wait4@@GLIBC_2.1 () from /lib/libc.so.6.1
No symbol table info available.
#1  0x20000a2f2fc in __libc_waitpid (pid=2025, stat_loc=0x11fffe930, options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:26
        in ../sysdeps/unix/sysv/linux/waitpid.c
No locals.

Attaching strace shows something of that sort
.....
1933  open("/usr/share/applnk/Settings/.directory", O_RDONLY) = 13
1933  fstat(13, {st_mode=S_IFREG|0644, st_size=1233, ...}) = 0
1933  read(13, "[Desktop Entry]\nName=Preferences"..., 1233) = 1233
1933  close(13)                         = 0
1933  stat("/usr/share/applnk/Settings/.directory", {st_mode=S_IFREG|0644,
st_size=1233, ...}) = 0
1933  open("/usr/share/applnk/Settings/.directory", O_RDONLY) = 13
1933  fstat(13, {st_mode=S_IFREG|0644, st_size=1233, ...}) = 0
1933  mmap(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x20000046000
1933  read(13, "[Desktop Entry]\nName=Preferences"..., 8192) = 1233
1933  read(13, "", 8192)                = 0
1933  close(13)                         = 0
1933  munmap(0x20000046000, 8192)       = 0
1933  gettimeofday({1012444283, 671023}, NULL) = 0
..........
1933  gettimeofday({1012444283, 671755}, NULL) = 0
1933  --- SIGSEGV (Segmentation fault) ---
.....

and in the meantime logs register these:

panel(1933): unaligned trap at 0000020000989a28: 000000011fffeeb4 29 18
panel(1933): unaligned trap at 0000020000989a54: 000000011fffeeb4 29 2
panel(1933): unaligned trap at 0000020000989a60: 000000011fffeeb4 2d 2
panel(1933): unaligned trap at 0000020000989a28: 000000011fffece4 29 18

Accordingly to my experiences from the past I would bet on a scribble
over a non-owned memory or an extern variable which is 'int' in one
place and 'long' somewhere else (which is pretty close to the reason
number one :-) and, if you are "lucky", will cause unaligned traps
on accesses to such thing, or not, depending on how such thing is
allocated in memory.

How Reproducible:

Like a clockwork.
Comment 1 harry.heinisch 2002-01-31 22:42:01 EST
This is a duplicate of bug# 58739, though much more thorough... ;-}
Comment 2 Beth Uptagrafft 2002-02-11 17:51:41 EST
This case is a duplicate of 58739 and will be closed as a duplicate.

*** This bug has been marked as a duplicate of 58739 ***

Note You need to log in before you can comment on or make changes to this bug.