Bug 587566 - broken or deprecated mime type
Summary: broken or deprecated mime type
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: desktop-file-utils   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 590168 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 09:43 UTC by Rudolf Kastl
Modified: 2011-09-28 09:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-28 09:49:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 420795 None None None Never

Description Rudolf Kastl 2010-04-30 09:43:13 UTC
Description of problem:
Error in file "/usr/share/applications/fedora-gspectrum-0.12.desktop": "chemical/x-jcamp-dx" is an invalid MIME type ("chemical" is an unregistered media type)

Version-Release number of selected component (if applicable):
gnome-chemistry-utils-0.11.91-1.fc14.x86_64

Comment 1 Rudolf Kastl 2010-04-30 12:23:13 UTC
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-xyz" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-mdl-molfile" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-pdb" is an invalid MIME type ("chemical" is an unregistered media type)

* same with those above

Comment 2 Julian Sikorski 2010-05-02 07:26:23 UTC
I don't understand, these mimetypes are provided by chemical-mime-data package.

Comment 3 Julian Sikorski 2010-05-07 21:42:48 UTC
*** Bug 590168 has been marked as a duplicate of this bug. ***

Comment 4 Bug Zapper 2010-07-30 11:31:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Edgar Hoch 2010-12-28 18:19:46 UTC
The problem still exist with a new fedora 14 installation with updates repo included.

gnome-chemistry-utils-0.12.5-2.fc14.x86_64

Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-mdl-molfile" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-pdb" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-xyz" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-cdx" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-cdxml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-mdl-molfile" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-ncbi-asn1-binary" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-ncbi-asn1" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-ncbi-asn1-xml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-pdb" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gcrystal-0.12.desktop": "chemical/x-cif" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gcrystal-0.12.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gspectrum-0.12.desktop": "chemical/x-jcamp-dx" is an invalid MIME type ("chemical" is an unregistered media type)

A note: There exists bugs number 587583 and 587575 which describe a simular problem. Maybe the problems are related?

Comment 6 Julian Sikorski 2011-02-12 09:38:35 UTC
There is a detailed discussion in debian bts, basically chemical mime types are unregistered and that's why they come in a separate package, it is either update-mime-database or update-desktop-database which is too picky.

Comment 7 Hans de Goede 2011-09-28 09:49:00 UTC
This is fixed by this upstream commit:
http://cgit.freedesktop.org/xdg/desktop-file-utils/commit/src/mimeutils.c?id=35cfa21227e77a80d8ccf1759ce23565fac3960e

Which is in the upstream 0.18 release, which we've in F-15 and later. Giving that this is just a warning I don't think this warrants doing an update for F-14 -> closing.


Note You need to log in before you can comment on or make changes to this bug.