Bug 587583 - broken or deprecated mime type
Summary: broken or deprecated mime type
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: avogadro   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 590170 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 10:10 UTC by Rudolf Kastl
Modified: 2011-04-26 23:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 23:02:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rudolf Kastl 2010-04-30 10:10:51 UTC
Description of problem:
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-cif" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-daylight-smiles" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-gamess-input" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-gamess-output" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-gaussian-log" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-mopac-out" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-pdb" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-xyz" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-gaussian-checkpoint" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-gaussian-cube" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/avogadro.desktop": "chemical/x-qchem-output" is an invalid MIME type ("chemical" is an unregistered media type)


Version-Release number of selected component (if applicable):
avogadro-1.0.0-6.fc13.x86_64

Comment 1 Sebastian Dziallas 2010-05-07 15:03:41 UTC
Ouch. Yup, right. Well, sounds like we'll either have to revive the avogadro.desktop (which is still in Fedora's CVS and was used originally) or patch the stuff out of upstream's (and get them a ticket).

Comment 2 Sebastian Dziallas 2010-05-08 09:39:43 UTC
*** Bug 590170 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Admin XMLRPC Client 2010-07-27 17:31:45 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Bug Zapper 2010-07-30 11:31:52 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 mark hewitt 2011-02-04 09:20:12 UTC
Today's update seems to have reintroduced this bug for me at least:


  Updating       : audacious-plugins-freeworld-aac-2.4.3-1.fc14.1.x86_64                                                                                                                                         1/40 
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-pdb" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-cdx" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-cdxml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-mdl-molfile" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-ncbi-asn1" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-ncbi-asn1-binary" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchempaint-0.12.desktop": "chemical/x-ncbi-asn1-xml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/kde/printers.desktop": "print/manager" is an invalid MIME type ("print" is an unregistered media type)
Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/gnome-default-handler" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Warning in file "/usr/share/applications/gnome-nautilus-folder-handler.desktop": usage of MIME type "x-directory/normal" is discouraged ("x-directory" is an old media type that should be replaced with a modern equivalent)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-xyz" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-mdl-molfile" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-pdb" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gchem3d-0.12.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gcrystal-0.12.desktop": "chemical/x-cif" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gcrystal-0.12.desktop": "chemical/x-cml" is an invalid MIME type ("chemical" is an unregistered media type)
Error in file "/usr/share/applications/fedora-gspectrum-0.12.desktop": "chemical/x-jcamp-dx" is an invalid MIME type ("chemical" is an unregistered media type)

Comment 6 Kevin Kofler 2011-02-04 16:48:59 UTC
None of these are in avogadro. Please file separate bugs against the packages which contain the offending .desktop files (use e.g. "rpm -qf /usr/share/applications/kde/printers.desktop" if you're unsure).

Comment 7 Kevin Kofler 2011-04-26 23:02:17 UTC
The Avogadro bug has been fixed months ago, please file a separate bug against each affected package.


Note You need to log in before you can comment on or make changes to this bug.